Support » Plugin: WP Post Signature » Excluding from Custom Post Types

Viewing 14 replies - 1 through 14 (of 14 total)
  • If I turn off the signature it comes off the page but also off all pages. Not ideal I only want to ensure that this custom post type is not included. There are other post types where it is not showing, so any help would be great!

    Can I get a little help with this? The new plugin is unusable until I can get the signature to not be shown on the custom post type.

    Plugin Author Soli

    (@allnull)

    You could put the post into a special categroy, and uncheck that category in ‘Which categories should the signature be placed?’ setting.

    Please let me know if that is what you want.

    The issue is the new plugin does not have a traditional “edit” page for me to assign a category to it. I do know the post type is called ghangout, but I have yet to figure out a way to see the post in traditional edit mode so I can assign a category.

    I think if we could just exclude the custom post type name like we do with the category that’s a win as well. Can that be done and added to the UI?

    another plugin called plugin organizer actually shows the custom post types in it’s settings. So a global setting that enumerates and allows selection of the known custom post types would be ideal 🙂

    Plugin Author Soli

    (@allnull)

    As you wish.

    Please update to v 0.2.2, and tell me if it is ok.

    Works Perfect!! Great addition!

    However it looks like it changed something on my home page that is using the tpg_get_posts. The signature was never being shown on all the home pages before as I have the –More– tage used as well. so just need to fix that. it was not showing before the update with the custom posts add.

    I do not have “Pages” selected and the site is using a page for the home page. I can try removing the plugin from that page with the plugin organizer too.

    Yep that worked. It seems the filter to not include it on pages was not working since I used plugin organizer to diabled the plugin on the home page it looks fine now.

    Plugin Author Soli

    (@allnull)

    glad you fixed it.

    thank you for your feedback. ^_^

    I fixed it with the workaround, but you may want to look into why the page filter was not working but the custom post type is.

    Plugin Author Soli

    (@allnull)

    I think the content of home page is some posts grabbed by tpg_get_posts.

    So, the home page actually is a list of posts.

    Please try check “No” of the “Will the signature be appended to the posts in archive or category list?” setting, and see what happened.

    However, there is no way for the plugin to find out if the post is requested by tpg_get_posts or by users. Is it?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Excluding from Custom Post Types’ is closed to new replies.