Support » Plugin: W3 Total Cache » Excluding folders in wp-content/uploads from CDN

  • How can you exclude directories from being rewritten to download from your CDN?

    I’ve tried every combination of folder paths I can think of and none of them prevent W3 Total Cache from rewriting the URLs that reference files in my wp-content/uploads/siteimages folder. This folder contains items I manually uploaded via FTP and am referencing on the site in certain widgets. W3 is breaking these images on my site because it’s rewriting them to Amazon S3 urls when the files are not on Amazon S3, nor are they scheduled to be uploaded by W3. This could be a problem for a number of other plugins that use the Uploads folder for things like backups as well.

    W3 seems to be set to rewrite all URLs that reference anything within Uploads if you have “Host Attachments” checked.

    In the field below labeled “Disable CDN on the following pages:” I’ve tried the following and none work:

    /kunden/homepages/33/xxxxxxxxxx/htdocs/testsite/wp-content/uploads/siteimages/
    /kunden/homepages/33/xxxxxxxxxx/htdocs/testsite/wp-content/uploads/siteimages/*
    /tempsite/wp-content/uploads/siteimages/
    /tempsite/wp-content/uploads/siteimages/*
    tempsite/wp-content/uploads/siteimages/
    tempsite/wp-content/uploads/siteimages/*
    /wp-content/uploads/siteimages/
    /wp-content/uploads/siteimages/*
    /wp-content/uploads/siteimages
    wp-content/uploads/siteimages/
    wp-content/uploads/siteimages/*
    wp-content/uploads/siteimages
    my-domain-name.com/wp-content/uploads/siteimages/
    my-domain-name.com/wp-content/uploads/siteimages/*

    The first two are absolute file paths in Linux. The rest are variations of the URL to the folder.

    I do not have any kind of page caching on, only S3 CDN for attachments only.

    https://wordpress.org/plugins/w3-total-cache/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    I also want to exclude some files in the upload folder.

    Now I disabled the host attachment function in Cdn settings in w3 total cache.

    How have you solved this issue?

    Thanks in advance.

    Greetings,
    Robin

    Hi,

    I never solved the issue. My workaround was to manually upload the siteimages folder to S3. I could not get w3 to not rewrite those folders. Exclusion doesn’t work. Now whenever I add a file to uploads/siteimages via FTP, I have to manually sync it on S3.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Excluding folders in wp-content/uploads from CDN’ is closed to new replies.