Support » Plugin: Yoast SEO » Excluded pages still appear in Yoast XML sitemap

  • Resolved sadhaka

    (@sadhaka)


    I have excluded pages from xml sitemaps yet one page still appears in it.

    It is the “Posts Page” which is the static page which shows the latest posts.

    I excluded it (via excluding all pages) because I only want individual posts to be indexed.

    But it still appears in the Yoast sitemap.

    Why is this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter sadhaka

    (@sadhaka)

    Ah – I think I got rid of it from the XML sitemap by using the “advanced” Yoast setting on the page, and explicitly choosing “No” – instead of leaving the “Default for pages, currently: No”, which should have excluded it, so there’s a bug there … perhaps every to-be-excluded page needs checking like this ? Otherwise I can see Google getting confused about this.

    Thread Starter sadhaka

    (@sadhaka)

    I thought I had excluded it by the method above, but it’s still appearing. This is buggy …

    Saša

    (@stodorovic)

    It’s an issue because “posts page” is the page and the archive page of posts (at same time). The page sitemap could include it as regular page (but it’s automatically excluded if it’s set as “posts page“). You see “posts page” at the top of the post sitemap because it’s post type archive.

    There is the workaround which retrieves “noindex” (for post type archive) from “posts page“. It’s reason why you need to explicitly set “noindex” for “posts page” if you want to exclude it from the post sitemap.

    It should work on this way.

    Thread Starter sadhaka

    (@sadhaka)

    Saša – not sure I get what you mean entirely, but I find now that the posts page does seem to be excluded from the sitemap if I specifically exclude it by using the “advanced” Yoast setting on the page and choosing “No” (and not the default, which actually was “No”, but that didn’t work). It didn’t seem to be excluding it at first, but now it looks like it is (I can’t see it in the sitemap, anyway). Maybe some cache or similar wasn’t purged.

    • This reply was modified 1 year, 2 months ago by sadhaka.
    Saša

    (@stodorovic)

    Yes, it’s exactly what I wrote. You need explicitly set “Allow search engines to show this Page in search results?” to “No“. It doesn’t work in other case. It’s special page and it’s only way to exclude post type archive.

    Additional problem could be transient caching (some plugins/themes enable it regardless that’s disabled by default – eg. Divi). It’s possible that you needed to disable/enable sitemaps (or delete transients) and then purge other caches. Maybe, after some time (24hrs) it worked automatically (because transients are expired)…

    Thread Starter sadhaka

    (@sadhaka)

    This will not work properly for the site root however. If your “Front Page” (home page/root) is a WordPress page, then excluding it in the in-page panel’s “advanced” section in the page does give it a “robots noindex” but it nevertheless still appears in the xml sitemap.

    (I have a particular reason for excluding my root/home page – it is only a video with navigation and therefore very “thin” content for Google and likely to be penalised if submitted.)

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Excluded pages still appear in Yoast XML sitemap’ is closed to new replies.