Support » Plugin: WP Super Cache » Excluded page being cached (using .htaccess)

  • After adding an item to the cart, the page is redirected to /checkout/
    which we have added to the exclusion.

    However the issue is the /checkout/ page is always show as empty.

    (we are using .htaccess)

    16:11:07 4997 /checkout/ wpsc_get_auth_cookies: no auth cookies detected
    16:11:07 4997 /checkout/ wpsc_is_caching_user_disabled: false
    16:11:07 4997 /checkout/ wp_cache_get_cookies_values: return: 
    16:11:07 4997 /checkout/ supercache dir: /var/www/activewords.com/html/wpaw/wp-content/cache/supercache/activewords.com/checkout/
    16:11:07 4997 /checkout/ No Super Cache file found for current URL: /var/www/activewords.com/html/wpaw/wp-content/cache/supercache/activewords.com/checkout/index-https.html
    16:11:08 4997 /checkout/ wp_cache_get_cookies_values: return: 
    16:11:08 4997 /checkout/ In WP Cache Phase 2
    16:11:08 4997 /checkout/ Setting up WordPress actions
    16:11:08 4997 /checkout/ Created output buffer
    16:11:08 4997 /checkout/ wp_cache_get_cookies_values: return: 
    16:11:08 4997 /checkout/ wpcache_do_rebuild: doing rebuild for /var/www/activewords.com/html/wpaw/wp-content/cache/supercache/activewords.com/checkout/
    16:11:08 4997 /checkout/ wpcache_do_rebuild: exiting as directory is not a directory: /var/www/activewords.com/html/wpaw/wp-content/cache/supercache/activewords.com/checkout/
    16:11:08 4997 /checkout/ DONOTCACHEPAGE defined. Caching disabled.
    16:11:08 4997 /checkout/ wp_cache_maybe_dynamic: returned $buffer
    

    And here is the .htaccess – seems to be duplicated 3 times?

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    #If you serve pages from behind a proxy you may want to change 'RewriteCond %{HTTPS} on' to something more sensible
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} ^$
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz -f
    RewriteRule ^(.*) "/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} ^$
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} ^$
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} on
    RewriteCond %{DOCUMENT_ROOT}/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html -f
    RewriteRule ^(.*) "/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index-https.html" [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} ^$
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTPS} !on
    RewriteCond %{DOCUMENT_ROOT}/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html -f
    RewriteRule ^(.*) "/wpaw/wp-content/cache/supercache/%{SERVER_NAME}/$1/index.html" [L]
    </IfModule>
    # END WPSuperCache
    
    # BEGIN block author scans
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} (author=\d+) [NC]
    RewriteRule .* - [F]
    # END block author scans 
    
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    
    RewriteRule ^videos/(.*)$ https://aw3.activewords.com/videos/$1 [R=302,QSA,L]
    RewriteRule ^support.html$ https://aw3.activewords.com/support.html [R=302,QSA,L]
    RewriteRule ^applications.html#Default$ https://aw3.activewords.com/applications.html#Default [R=302,QSA,L]
    RewriteRule ^dragdrop.html$ https://aw3.activewords.com/dragdrop.html [R=302,QSA,L]
    RewriteRule ^AWImport.html$ https://aw3.activewords.com/AWImport.html [R=302,QSA,L]
    RewriteRule ^AWSharedWB.html$ https://aw3.activewords.com/AWSharedWB.html [R=302,QSA,L]
    
    RewriteRule ^cgi-bin/buynow.cgi$ https://activewords.com/renewing-activewords-3-licenses [R=302,QSA,L]
    RewriteRule ^buyactivewords.html$ https://aw3.activewords.com/buyactivewords.html [R=302,QSA,L]
    RewriteRule ^keyrequest.html$ https://aw3.activewords.com/keyrequest.html [R=302,QSA,L]
    RewriteRule ^activewordsannuallicense.html$ https://aw3.activewords.com/activewordsannuallicense.html [R=302,QSA,L]
    
    RewriteCond %{REQUEST_URI} !^/wpaw/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ /wpaw/$1
    
    RewriteCond %{HTTP_HOST} ^activewords.com$
    RewriteRule ^(/)?$ /wpaw/index.php  [L]
    </IfModule>
    

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Donncha Ó Caoimh

    (@donncha)

    Anything in your PHP error log? I don’t think it’s the plugin as caching is disabled on your checkout page. Disable WP Super Cache and see if that fixes the checkout page.

    Its seems to be related to needing to have the Advanced option, Enable Dynamic Caching checked – which does not seem possible in Advanced mode (using .htaccess).

    If I put it back to basic mode and enable the option then our checkout page works.

    Can you explain this please?

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    That’s good. Simple mode just uses PHP to serve the cache, and in most cases it’s 99.999999% (err, probably) as fast as advanced mode so if it works I’d leave it like that. You’re not missing out.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.