WordPress.org

Forums

Google Analytics Dashboard for WP
[resolved] Exclude Tracking function (6 posts)

  1. Jackflash101
    Member
    Posted 1 year ago #

    On our client's site, I've set the "Exclude Tracking for" to contributors. (did so about 3 days ago). As I remember, from discussion on your web site, that should exclude all traffic when logged in for all users, "contributors" and above. BUT it doesn't seem to be working right, as over the last several days, there are 8 total visits shown on GA for my city, but only 2 are new visitors.

    I tried excluding I.P. addresses before, using the GA filter to do so, but that isn't working either.

    Also, the blue box on the dashboard, which normally shows "visits" "visitors" "page views" etc. keeps showing 0 info. What is going on? It has normally worked fine on other web sites.

    http://wordpress.org/plugins/google-analytics-dashboard-for-wp/

  2. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    Let's make some tests:

    1. Go to Settings -> GA Dashboard -> Exclude tracking for: and select Disabled.

    Log in as an Administrator, go to your website and open a view page source (in Chrome CTRL+U), search for "UA-", if you find that twice, then probably you (manual edit) or a third-party plugin is also inserting the tracking code.

    2. If you find it once, go to Settings -> GA Dashboard -> Exclude tracking for: and select Contributors and clear cache (if you use a cache plugin). Can you find it now?

    Is normal to show zero if there are no visits on selected interval. Also, if you visit the site and you're not logged in (browsing as a guest) you will be counted as a visitor.

  3. Jackflash101
    Member
    Posted 1 year ago #

    Hi Alin-- Thanks for the quick reply.

    I found it twice on the home page, but not at all sure what I'm looking at.

    It is once in the HEAD section:

    "<head>
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>"

    -----Then also, in a JQUERY script-----

    "</script><script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-47042503-1'], ['_gat._anonymizeIp'], ['_trackPageview']);
    (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
    </script>

    ALSO, if I CLEAR CACHE (blue button on your plugin's functions) is that what I should do? What does it do exactly?

  4. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    It's only once,

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

    has nothing to do with tracking, my mistake.

    Ok, now make the test for step two (2.), and look for: UA-47042503-1. If you can't find it, while being logged in, the exclude filter works properly.

  5. Jackflash101
    Member
    Posted 1 year ago #

    Alright! I tried that, and it seems to be working. I guess you meant for me to, after clearing the cache, to check the page source for UA-47042503-1 without going back to "disabled" for EXCLUDE TRACKING? I'm pretty sure that's what you meant. So seems to work fine.

  6. hays298
    Member
    Posted 1 year ago #

    Hi Alin,

    I was looking for a way to do the same thing. I can't find Exclude tracking for: anywhere on the dashboard though. Could you shed some light?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics Dashboard for WP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.