Support » Plugin: Rich Table of Contents » Exclude the RTOC display on FrontPage

  • Resolved peteraloha

    (@peteraloha)


    Love the RTOC plugin, AND have an issue to exclude its display on the FrontPage:

    Using the Page ID as suggested to exclude it, the TOC still displays on the frontpage (currently eliminated by requiring 4 titles to display RTOC).

    The page ID used is what shows up in the URL for the FrontPage “https://swisscryptostrategies.com/” – can you verify that page ID is indeed = 80?

    Any input is greatly appreciated!

    Peter

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Croover.inc

    (@ryota0101)

    Hi @peteraloha !

    Thank you for using our plugin!
    I’m not sure I understand the situation. Do you want to prevent the RTOC table of contents from being displayed on the top page?

    Best Regards!
    Ryota

    Thread Starter peteraloha

    (@peteraloha)

    Ryota:

    THANK YOU for responding – your plugin is TERRIFIC.

    I do *not* want the TOC to show on the FrontPage (top page).
    The only option in the settings suggests to use the page ID to accomplish that.
    In my case, the page ID is “80” – and even though I put “88” in the settings, the TOC still pulls up on the top page – and now I just re-did the settings and the TOC is no longer pulling up on the frontpage, so it seems resolved. Yesterday it didn’t work – sorry to bother you about it.

    Best regards,

    Peter (*really* love the look of your TOC)

    Plugin Author Croover.inc

    (@ryota0101)

    Hi Peter!

    I’m very happy to hear that because I put a lot of time and effort into the look.

    Could you please share the top page where the table of contents is actually displayed?
    I think I can reproduce the same problem if I know how to make it, and if I know the cause, I may be able to share the solution.

    I can’t see the first URL you shared because it jumps to 404.
    I know it’s a lot of work, but I’d appreciate it if you could help me out.

    Best regards

    Ryota(Your site design very nice)

    Thread Starter peteraloha

    (@peteraloha)

    Dear Ryota,

    THANK YOU – it is now all working, and here is the only page where *I want* the TOC to display:

    https://swisscryptostrategies.com
    Then go to the “workspace” page!

    I am very happy to know that you are available should I have any issues in the future.
    This is the *cleanest* looking TOC by far that I have seen! GREAT DESIGN WORK!

    Best regards,

    Peter

    • This reply was modified 8 months, 1 week ago by peteraloha.
    Plugin Author Croover.inc

    (@ryota0101)

    Dear Peter,

    Thanks for sharing the URL.

    When I tried to visit the page, I couldn’t see it because it seemed to require a password.
    It would be great if you could temporarily remove the password lock.

    Thank you very much.
    I’m very happy to know that people are using it too. I’ll keep working on it!

    Best regards,

    Ryota

    Thread Starter peteraloha

    (@peteraloha)

    ooooooooooops, sorry, my bad, Ryota, pw protection is removed!

    Peter

    Plugin Author Croover.inc

    (@ryota0101)

    Ok,Thanks Peter!

    https://swisscryptostrategies.com/workspace/

    Hmmm, when I checked this page, the page id was “23”, but when I enter this number into the “Page ID to exclude” in the RTOC settings page, it is not reflected?

    I also tried to make my environment match Peter’s site, but it’s reflected correctly and I can’t confirm the problem.

    https://gyazo.com/3bc8fcc04ac6f8996fef84092a69b186

    Please refer to the URL I sent you and check if it is set correctly again.

    Ryota

    • This reply was modified 8 months, 1 week ago by Croover.inc.
    Thread Starter peteraloha

    (@peteraloha)

    Ryota,

    THANKS! – all is well now – and my original concern was that entering the page/post ID for “exclusion” in the RTOC settings didn’t readily work, prompting me to open this thread.

    Meanwhile you explained and addressed all concerns and everything *works* as expected.

    Again: This is BY FAR THE MOST BEAUTIFUL TOC plugin – THANK YOU so much for sharing it!
    Do you have a website or “news” to subscribe to so I get notified when you have additional plugins to share?

    Best regards,

    Peter

    Plugin Author Croover.inc

    (@ryota0101)

    Dear Peter,

    I’m glad to hear that you were able to solve the problem safely.
    If you have any problems, please feel free to ask me anytime. We are always here to help.

    I don’t have any plugins or sites to share with you, so if you continue to use Rich Table of Contents, I’ll be happy.
    I’ll be happy if you continue to use Rich Table of Contents.

    I will continue to upgrade as much as I can and add new features as well.

    It would be a great honor to be a developer if you could look forward to those features and designs.

    I can’t say it well enough, but I’m glad we were able to work it out together.
    Keep up the good work!
    (I’ll mark this topic as resolved!)

    Ryota

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Exclude the RTOC display on FrontPage’ is closed to new replies.