WordPress.org

Forums

Image Wall
[resolved] Exclude Tags (4 posts)

  1. BigDogSF
    Member
    Posted 2 years ago #

    Hi, First, nice fun plugin! I'm using Paul Menard's "Media Tags" plugin for tagging on my media library.

    I can't get the exclude_tags= function to perform. I have tried it in all these different manners:

    exclude_tags='1750' (tag id)
    exclude_tags="1750" (tag id)
    exclude_tags='Site Images General'
    exclude_tags="Site Images General"
    exclude_tags='site_images_general'
    exclude_tags="site_images_general"
    exclude_tags='site-images-general'
    exclude_tags="site-images-general"

    Is this issue possibly being caused because your plugin does not recognize the tags created by the Media Tags plugin?

    What to do?

    Regards,
    Will

    http://wordpress.org/extend/plugins/image-wall/

  2. BigDogSF
    Member
    Posted 2 years ago #

  3. Parakoos
    Member
    Plugin Author

    Posted 2 years ago #

    Hello!

    I'm glad you like the plugin.

    The filter arguments work to filter out images that are attached to posts where the post has (or does not have) the given categroy/tag. So if you have a category of posts called 'cats', and in that category you create a post named 'Fluffy' with three images of the little hairball, then those three images would not be shown on the image wall (given that you've excluded 'cats')

    In other words, no, the image wall does not recognize (or even know about) the media tags that you've added to your images using that third-party plugin. WordPress does not have tags or categories for individual media files.

    Sorry to not be able to help you more, but hope you might be able to use the post-wide tag/category filter to do what you want.

    Please rate the plugin if you like it!

  4. BigDogSF
    Member
    Posted 2 years ago #

    Thanks for the quick response! I figured out a work-around. U See, I have advertising sliders on the website..and the images were not attached to any post type, and therefore not attached to a category.

    So what I have done is really quite simple. I created a new post category, advertising, and then created a new post, Media Sliders...which I am not displaying anywhere.

    Then I went to my media library, and attached all the unattached advertising slides to the new post, Media Sliders...and excluded the category slug "advertising-2" using the exclude_categories option.

    It works!

    Regards,
    Will

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Image Wall
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic