Support » Plugins » Exclude Pages isn’t exlcuding pages

  • I want to exclude gravatars from Pages, but haven’t had any success. In the plugin admin panel under Presentation, I checked the radio button for Exclude Gravatars, Favico and MyBlogLog from Pages, but it isn’t excluding for me. Does anyone else have this problem or know a good fix?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi gregargo!

    Could you check if the options are being written to the database?
    Do you get any error messages?

    I’ve tested it on 2.1, 2.2, 2.3.1 and 2.3.2, and it works fine on all of those.

    Regards,
    Rune

    Thanks Rune-

    I deactivated and removed the plugin, and removed the options from wp-options in the database. Then I reinstalled the plugin, and the options came back in wp-options, so it looks like they’re being written. Any other ideas?

    Greg

    Well, Greg, I’m sorry to say, I don’t have any good ideas.

    Just to be sure, we are talking about WordPress Pages – right?

    If that is the case, it is kinda strange, since the plugin uses is_page to check if it is as page or not…

    Have you used any other Gravatar plugins that’s still active? Or have you hardcoded some Gravatar code in you comments template?

    I’m sorry that I can’t give you any better help!

    Regards,
    Rune

    I’m having the exact same issue on my site… the options are being saved to the database but the gravatar still shows up on pages regardless of the checkbox value.

    I’m using WP 2.3.3 and I just installed the gravatar plugin today… it’s a new blog too and gravatar is only the 2nd plugin I’m using and the only one that deals with page entries (the other one just does database backups)

    I took at a look in the plugin code and while the option exists I guess I don’t understand how it would stop the gravatar from showing up on pages.

    the only time where I see the “no page gravatar” option being checked is in the show_gravatar() function… and the only time that is called is during the comment action.

    the checkbox should be controlling whether or not the gravatar is amended to a ‘the content’ filter but I don’t see that option getting called in any of the functions attached to the content filters.

    I could be wrong but it’s hard to follow seeing there aren’t any comments in the code :-/

    in otherwords. the checkbox looks like it would stop gravatars from comments on pages but not on the page content itself.

    My suspicions were correct…

    I added this line of code:

    If (is_page()){$post_gravatar = !(get_option('bruk_gravatar_pages'));}

    just before the if statement in the show_gravatar_post function and saved it.
    Now my gravatar doesn’t appear in pages but it does in posts. And the checkbox in the options has the desired effect. Unless the official wordpress plugin page is hosting an old version of the plugin (2.6.4) I guess I don’t understand how that checkbox would work for you but not for us considering I couldn’t find any hint in the code of it’s use beyond comments.

    this fix worked for me, too. nice job.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Exclude Pages isn’t exlcuding pages’ is closed to new replies.