Support » Plugin: SG Optimizer » Exclude page from being served with https

  • Resolved Fabio

    (@origamifc)


    Hi, I have enabled https with sg optimizer, however there’s a page on my site displaying a iframe that can’t be served via https, thus giving a blank result.

    Is there a way to edit the htaccess rules set by the plugin, so that the specific page can be served via http?

    Here’s the original rules

    # HTTPS forced by SG-Optimizer
    <IfModule mod_rewrite.c>

    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>

    What I need should be something like the following rule, but i don’t know if and how it can be integrated with sg optimizer htaccess rules.

    RewriteCond %{HTTPS} !=on [NC]
    RewriteCond %{REQUEST_URI} !/my-page/

    Thanks for the help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    This is not caused by the plugin. I believe you’ve enabled the Force HTTPS setting in either cPanel or Site Tools if youre new customer. The redirect rules are fine, they won’t affect iframes in anyway. Just disable the Enforce HTTPS service from Site Tools since the plugin is doing it and you will be fine 🙂

    Fabio

    (@origamifc)

    Hi, the site is on a addon domain for which I have enabled a let’s encrypt certificate.
    I’ve checked the let’s encrypt settings from cpanel and the https enforce option is disabled.
    Turning on the sg optimizer https option and visiting the page with the iframe, I get the mixed content error in the console, preventing the iframe content from being displayed.
    That’s why I wanted, if possible, to serve that page via http while the rest of the site remains on https.

    • This reply was modified 1 month ago by Fabio.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.