WordPress.org

Forums

Quick Cache (Speed Without Compromise)
[resolved] Exclude Facebook Feed from Cache? (5 posts)

  1. knucleheads
    Member
    Posted 1 year ago #

    Hello,
    I have installed Quick Cache because I arrived from s2Member Pro.
    From there, I realized you have a Pro version, and the price is great.
    So I upgraded, even though the Lite version (free) is doing everything I needed.

    I want to support developers that make great tools I use.

    Anyway, my issue at the moment:
    I am running the plugin Custom Facebook Feed Pro
    http://smashballoon.com/custom-facebook-feed

    How can I tell Quick Cache to NOT cache the images/posts from this Facebook feed?

    Feel free to ask for login information to my website if you need it.
    Thank you!

    https://wordpress.org/plugins/quick-cache/

  2. knucleheads
    Member
    Posted 1 year ago #

    Erm, sorry... adding more information:

    The reason I want Quick Cache to not cache the Facebook feed is that new posts from our Facebook page are not coming up.

    Custom Facebook Feed can be set to check for new posts every x-minutes or hours.
    We have it set to check for new Facebook posts every 1 hour (60 minutes).

    Yet with Quick Cache enabled, new posts never come up in our page.

    Any idea what we can do?
    Thanks!

  3. knucleheads
    Member
    Posted 1 year ago #

    Hello guys,
    I wanted to update something.

    When I opened up the page with the Quick Cache and Custom Facebook Feed Pro, it showed the old Facebook posts.
    I reloaded the page, and still nothing new (from the Facebook Feed).

    So I then logged into the Dashboard, and reloaded the home page (where the Facebook Feed is at).
    It then showed the new Facebook Feeds just fine.

    Any idea what could be going on?
    Or what I can do to troubleshoot this?

    MODIFIATION I DID:
    WordPress Control Panel --> Quick Cache
    I added

    akamaihd.net
    facebook.com

    To both: URI Exclusion Patterns and HTTP Referrer Exclusion Patterns.

    Thanks!!

  4. knucleheads
    Member
    Posted 12 months ago #

    Oddly enough, FireFox (29.0.1) is cache'n the Facebook posts from Custom Facebook Feed.

    Yet Google Chrome (35.0.1916.114 m) is not cache'n them.
    It's showing the latest.

  5. Raam Dev
    Member
    Plugin Author

    Posted 12 months ago #

    @knucleheads I replied to your ticket on our Support Center.

    Oddly enough, FireFox (29.0.1) is cache'n the Facebook posts from Custom Facebook Feed.

    Yet Google Chrome (35.0.1916.114 m) is not cache'n them.
    It's showing the latest.

    That's most likely because you were logged into WordPress on Google Chrome. Logged-In User caching is disabled by default in Quick Cache, so if you were logged in, you wouldn't see the cached page.

    For anyone else coming here looking for the answer to this question: If you have a dynamic portion of a page that you don't want to be cached, your only options are to exclude that entire page from the cache (using URI Exclusion Patterns, available in Quick Cache Pro) or make sure the plugin uses JavaScript to upate the dynamic portions. You may also want to contact the plugin developer to see if they can add support for Quick Cache using the Advanced Cache Plugin feature.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Quick Cache (Speed Without Compromise)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic