Support » Plugin: Wordfence Security - Firewall & Malware Scan » Exclude Directories from Wordfence

  • Jason Ryan

    (@viablethought)


    Hello –

    I am back with a similar yet different issue. I have a self-hosted CRM in a sub-directory off of my root directory where my WP install is that is running WF. Just recently, and coincidentally around the same time frame the last update came out, I began to experience issues with my CRM being able to make IMAP connections on my own server to be able to send mail.

    I kept checking server logs, mail logs, my CRM logs, and WF logs and there was no trace that WF was blocking these connections, however once I deactivated and deleted WF from my WP site in the root directory, my CRM went back to normail and was able to make IMAP connections again. As a test, I re-enabled WF on my site and sure enough within 12-14 hours of doing so, the same errors started showing up again in my logs with failed IMAP connections. Deactivated and deleted the plugin again and once cron cleared, my CRM went back to normal.

    That said, I am now without WF on my WP site because I need my CRM to run. These issues are surely being caused by WF somehow but nothing is showing up in logs to determine exactly what the issue is. Is there anywhere to completely disable WF from having ANY control over an app installed in a sub-directory?

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WFSupport

    (@wfsupport)

    You’d need to follow these instructions based on which setup you use.

    If using .user.ini, add a line to the directory’s .user.ini file (or create that file) in the folder of the directory you want skipped:
    auto_prepend_file = none

    If using .htaccess on PHP5 add a line to the directory’s .htaccess file (or create that file) in the folder of the directory you want skipped:
    <IfModule mod_php5.c>
    php_value auto_prepend_file none
    </IfModule>

    If using .htaccess on PHP7 add a line to the directory’s .htaccess file (or create that file) in the folder of the directory you want skipped:
    <IfModule mod_php7.c>
    php_value auto_prepend_file none
    </IfModule>

    Jason Ryan

    (@viablethought)

    Hello –

    Thanks @wfsupport for the response. I am going to let things settle for another and the give this a try. I’ll report back with my findings.

    @wfsupport

    Quick question for clarification, if the site is on PHP7 and I enable Wordfence – it creates a user.ini file – so both methods are in play here.

    So for the main site in the root directory:

    ROOT
    – .htacess
    – .user.ini

    Addon Domain/Sub Directory:
    – .htacess

    In this instance, which is the proper method to use? Add a user.ini file to the sub-directory or just add the line to the .htacess file?

    Thanks in advance.

    Hello –

    Anything on this? I keep running into issues with Wordfence blocking actions of apps in sub-directories/add-on domains.

    The sub-directory is PHP7 and I added the code from above to the directory’s .htaccess file but Wordfence is still blocking stuff:

    <IfModule mod_php7.c>
    php_value auto_prepend_file none
    </IfModule>

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Exclude Directories from Wordfence’ is closed to new replies.