Support » Plugin: Spam protection, AntiSpam, FireWall by CleanTalk » Excessive admin-ajax.php Server Load Time

  • Resolved crzyhrse

    (@crzyhrse)


    Using the Asset Cleanup Pro plugin I have removed Cleantalk on pages not needing spam protection, and this issue doesn’t occur on those pages, but on posts and pages with comments enabled, or with a contact form, and so where I am leaving Cleantalk still enabled, this issue does occur…

    Excessive admin-ajax.php server load time related to cleantalk is adding as much as 5 seconds to the final load time of the pages and posts…

    How can this be corrected…?

    The link I included in the field below the topic title is for one of those pages where the issue is occuring… And here is a link to a screenshot of what occurs at GTMetrix with what I believe are things related to Cleantalk highlighted…
    https://ibb.co/QKVR1Rb

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • Thread Starter crzyhrse

    (@crzyhrse)

    Hi @serge00

    I believe this latest Version 5.156.102 has partly helped… There is only one thing now, instead of two, related to cleantalk, that is taking a long time to complete, as shown at GTMetrix in the waterfall… 4+ seconds, whereas everything else is in milliseconds…

    Here is another screenshot showing this- https://ibb.co/HnwH1TS

    And if you go to GTMetrix and enter this url, https://www.ashlandspirit.net/about/ , to check, and look in the waterfall, you should see the same, with many more details…

    Plugin Support SergeM

    (@serge00)

    Thank you for your reply, @crzyhrse.
    I’ve passed your details to the programmer staff.
    We will write back to you within 1-2 business days. Please, wait.

    Plugin Author Denis Shagy

    (@shagimuratov)

    Hi @crzyhrse,

    I’ve tested the https://www.ashlandspirit.net/about/ by myself and found that the backend loads 4+ seconds.

    Our plugin does 1 request to the backend from the fronted too, that’s why we have 4+ second call in the waterfall at GTmetrix.

    So, could you check other plugins in your WordPress setup? Looks like something slows your site even if CleanTalk is disabled, because CleanTalk doesn’t affect the backend as mush as 4 seconds.

    PS
    Also, to cut off the delay on the waterfall turn the option ‘Use AJAX for JavaScript check’ off in the plugin settings. But it may drops anti-spam efficiency.

    PPS
    The links to the screenshots,
    https://ibb.co/gtMrCMv
    https://ibb.co/Nt1prXX

    • This reply was modified 1 month, 3 weeks ago by Denis Shagy.
    Plugin Author Denis Shagy

    (@shagimuratov)

    Hi @crzyhrse,

    We are going to release some improvements in our plugin, which should remove the last 4 seconds request.

    I hope the release will be ready to use till June 10. I will write you as it will be ready.

    Thread Starter crzyhrse

    (@crzyhrse)

    Hi @shagimuratov,

    I of course might wish it to be sooner, but I am very happy to hear this… I will watch for your messages about it… Thank you and kind regards…

    🙏🏽

    Plugin Support SergeM

    (@serge00)

    We do our best to improve the plugin performance as soon as possible.
    Please, wait.

    Plugin Author Denis Shagy

    (@shagimuratov)

    Hi @crzyhrse,

    We have improved the plugin performance. Please try to use this one version,
    https://github.com/CleanTalk/wordpress-antispam/releases/download/custom_ajax_handler/cleantalk-spam-protect-custom-ajax.zip

    The update guide is here,
    https://cleantalk.org/help/update-wordpress

    Also, please make sure that the option ‘Use ajax for js’ is turned on.
    WordPress console -> Settings -> Anti-Spam by CleanTalk -> Advanced settings -> Use ajax for js.

    Does it work better?

    Thread Starter crzyhrse

    (@crzyhrse)

    Hi @shagimuratov

    It DOES work better… in the GTmetrix waterfall that one thing that was still left relating to Cleantalk went from over 4 seconds down to a little over 0.4 seconds… Testing it on two sites show similar results…

    I’ll install it on some other sites as well and watch for a while, see that everything else is all right… But so far so good…

    When you update Cleantalk in the WP Plugin Repository I am assuming it will all update normally from this github version that I am going to leave installed the meantime…??

    And Thank you so much for being on top of this like you all are, and staying with it…

    Warm regards…

    Plugin Support katereji

    (@katereji)

    Hello.
    Thank you for the feedback.
    About your question regarding the next stable version of the plugin and new fixes, need to check with the developers. We will answer you within 24 hours.
    Be well.

    Plugin Author Denis Shagy

    (@shagimuratov)

    Hi @crzyhrse,

    Thanks for the great feedback and I’m glad that the issue is solved.

    We are going to include this patch in release 5.159 and bring out it in middle of June.

    I will let you know as it will be released.

    Plugin Support amagsumov

    (@amagsumov)

    Hello @crzyhrse

    We’ve released the 5.159 version today. Please use this guide to update the plugin:
    https://cleantalk.org/help/update-wordpress

    Did it help?

    Thread Starter crzyhrse

    (@crzyhrse)

    I am not finding any issues anymore related to CleanTalk, not in GTMetrix and not in the browser console… So I believe we can call this ticket resolved… Thank you so very much for all your attentiveness to this… It is VERY much appreciated…

    With warm regards…

    Plugin Support amagsumov

    (@amagsumov)

    Thank you for your feedback!

    Let us know if you have any questions.

Viewing 13 replies - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.