Support » Plugin: List category posts » Excerpts Losing Formatting

  • Resolved soulofmiami

    (@soulofmiami)


    Using theme Atahualpa. I have set the theme options to NOT strip certain HTML tags from excerpts, such as p a em strong. But, when I use [catlist excerpt=yes] it strips all formatting from the excerpt. In previous versions, it did not do this.

    By keeping the formatting, the Category lists created by this plugin look very nice and neat. By losing the formatting, the lists with excerpts just look bland and messy.

    Is there any way to fix this?

    Site is: http://www.soulofmiami.org. The Featured Events section on the stickied “Front Page” post should be neatly formatted like this:
    Date
    Location
    Address
    1 line description

    But, as you can see, it all runs together, making it difficult to read. I would love to see the formatting back, or an option to use the formmatting.

    Thanks for all your help!

    http://wordpress.org/extend/plugins/list-category-posts/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Fernando Briano

    (@fernandobt)

    I’ll check a way not to overwrite the theme’s filter for html tags in a future version.

    Thank you so much! It used to not do this, I’m not sure why it is now.

    jt70

    (@jt70)

    I have what I think is the same problem.

    Just updated to .28 (can’t recall from which previous version), and my excerpts are functioning differently now.

    I had been using he excerpt=yes parameter with no excerpt size parameter, and it used to display the complete excerpt with all of its HTML formatting. Now it just displays the text with all the tags stripped out.

    To be clear, I use manual excerpts. The text in the lists comes from the manual excerpt box, not from the post itself. They excerpts still show up in RSS feeds as designed, though.

    Thanks, by the way, for a great plugin.

    jt70

    (@jt70)

    Just curious if this is a systemic problem or something that is unique to me. Is anyone else having the html stripped out of manual excerpts (the excerpt box on the post page)?

    Because 2 new releases have come out since soulofmiami brought this up, I am wondering if it is an isolated issue related to conflicts or my theme (I’ve got a mish-mash custom theme going now). I just don’t want to spend the time diving into troubleshooting if the problem is inside the plugin.

    Any information would be much appreciated.

    Thanks!

    Plugin Author Fernando Briano

    (@fernandobt)

    Just a quick heads up that I’ll look into this, and in any case get a bugfix version out.

    jt70

    (@jt70)

    Thanks a lot. I appreciate the response.

    alixmaryo

    (@alixmaryo)

    Hi there,

    Has there been any progress on this? I’m experiencing the same problem. The html is always stripped from the excerpt even if you set it to not strip markup.

    Thank you so much for the plugin.

    Mary

    Bump

    I love this excellent plugin but I too would like a way to retain the formatting in the excerpt.

    Thanks and cheers, PH

    Hi Picandocodigo,

    Is there any chance you can let us know what the status of this issue is? I hate bugging people who are kind enough to do great plugins for free, but if this is going to be a long time or it is not something you think you’ll be able to fix, I’ll have to find an alternative for my site. Just an indication of when/if you will be able to get to this would be extremely helpful.

    Thanks again.
    Jeff

    **********
    To Other users:
    Has anyone started shopping around for alternatives to be able to list the excerpts with formatting intact? If so, would you mind sharing them? I did a cursory look, and nothing jumped out at me. I suspect it will require coding, which should be fun with my limited skills.

    Plugin Author Fernando Briano

    (@fernandobt)

    This has been fixed on version 0.30 of the plugin. By default, tags are not stripped. If you want to strip them, you must use the excerpt_strip parameter:

    [catlist name=blog excerpt=yes excerpt_strip=yes]

    Check it out and let me know how it works 🙂

    Uh oh….

    I think something broke on my site. Not sure if it is with the plugin or with how I do my formatting, but the lists cascade off to the right.

    It works nice with the posts I don’t have something loaded in the manual excerpts box. I suspect it has something to do with the tables/divs in my html.

    Thanks for trying.

    By the way, do you have .29 loaded in the repository? I couldn’t find it. I need to roll back the plugin.

    Plugin Author Fernando Briano

    (@fernandobt)

    What code are you using? Maybe remove styles or try the excerpt_strip param and see how it looks?

    Sorry, I already rolled it back to an earlier version so won;t be able to test right away.

    The catlist calls up a combination of manual and automatic excerpts. The formatting of the automatic is cleaner than in the past. The excerpt is on a new line and the title is on its own line.

    I use tables with a designated width to fit into the div on the template.I am wondering if the problem is that it is truncating the text and never closing out the tags in the excerpt. That would explain the formatting issues. I may have to go track down all my lists and then add in the excerpt_size = 1000 to fix the problem.

    I’ll let you know if that fixes things.

    OK, I was too curious not to test this out, so I reinstalled the .30 version.

    Yes, it looks like with a higher excerpt_size (set to 1000), it work for the formatting. Unfortunately, that also raises the excerpt size for the automatic excerpts.

    As is, this version will work great for a completely automatic list, or a completely manual list, but with a mixture of the two, it creates a problem. It will either truncate the manual excerpt and leave tags open, or it will create excessively long excerpts.

    It seems like the functionality it needs is to always pull the entire manual excerpt, but trim the automatic excerpts to either the default or the excerpt_size.

    Thanks for working on this.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Excerpts Losing Formatting’ is closed to new replies.