Support » Plugin: Organize Series » Excerpt not displayed with Elementor

  • I’m running:

    WordPress 5.2.3
    Elementor 2.7.5
    Elementor Pro 2.6.1
    Organize Series 2.5.12

    Using Elementor’s “Hello” theme, I’m trying to set up a basic template for my home page. Existing posts have a combination of custom-entered excerpts and some where I didn’t specify, so the expected default behavior would be for the first N characters to be used as the excerpt.

    I wanted a block to display several recent posts with their thumbnails and excerpts, so using Elementor, I added a section block and dragged the Elementor “Posts” widget into that block. It mostly worked, *except* no excerpts appeared, even with the corresponding toggle switch for the widget set to “show excerpt”. Thinking it might be a problem with that specific widget, I then tried WordPress’s own “Recent Posts” widget, and the same thing occurred – no excerpts displayed.

    To troubleshoot, I turned off most of my plugins and that made the excerpts show up in both posts widgets as expected. I turned plugins on one at a time to find the culprit and as soon as I re-activated Organize Series, the excerpts disappeared.

    I’ve browsed other series and taxonomy plugins, but none offer quite the combination of features that led me to choose Organize Series in the first place. I’ve already used it on posts pre-dating the re-design, so I’m reluctant to give it up. I need excerpts to work in my widgets, though. Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Excerpt not displayed with Elementor’ is closed to new replies.