Excerpt Issues (2 posts)

  1. joeykirk
    Posted 5 years ago #

    I'm working on a site for a client. For some reason, when the client fails to put in the Excerpt in a post, this shows up:

    Warning: call_user_func_array() [function.call-user-func-array]: First argumented is expected to be a valid callback, 'new_excerpt_more' was given in /nfs/c05/h03/mnt/75928/domains/horiquah.com/html/dev/wp-includes/plugin.php on line 166

    Line 166 says:
    $value = call_user_func_array($the_['function'], array_slice($args, 1, (int) $the_['accepted_args']));

    In my home.php I have this:

    <?php while (have_posts()) : the_post(); ?>
    			<div <?php post_class() ?> id="post-<?php the_ID(); ?>">
    				<h2 id="main-headline"><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h2>
    				<small><?php the_time('j | F | Y') ?></small>
    				<?php if (function_exists('the_subheading')) { the_subheading('<h3>', '</h3>'); } ?>
    				<div class="entry">
    					<p><?php the_excerpt(); ?>
    <a class="learnmore" href="<?php the_permalink() ?>">... Learn More <img src="http://new.stoneyriverweb.com/wp-content/themes/Stoney River/images/arrow.png" width="6px" height="12px" /></a></p>

    Does anyone have some thoughts on how to prevent this? Or at least get back to where if the user didn't put in the manual excerpt, the first 55 words would appear?

    The site is hosted right now at http://horiquah.com/dev

    I would appreciate any help.

  2. Michael
    Part-Time Forum Moderator
    Posted 5 years ago #

    did you check functions.php of the theme, if there are some lines to do with applying filters for 'new_excerpt_more':
    like in

Topic Closed

This topic has been closed to new replies.

About this Topic