Support » Plugin: Post SMTP Mailer/Email Log » Exception Code = 550

  • Resolved Gerdski

    (@gerdski)


    Hello,

    since installing the Plugin in Our WooCommerce-Shop, we get many errors in this Form:


    ERROR PostmanWpMail: Exception code=550 message=You are not allowed to use the domain web.de as DATA From domain.

    This happens when customers of the shop have a web.de eMail address (which is very common in Germany), also the Shop owner has one. Probably the FROM address comes from the customer settings in WooCommerce.

    What can we do about that?

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    Unfortunately this is an issue with your configuration, not the plugin. The 550 error is produced by your SMTP server.

    Please paste a copy of your Post SMTP diagnostics log here, and we will try to advise what is not configured correctly.

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    Hi,

    ok, here is the log:


    Mailer: postsmtp
    HostName: mydomain.com
    cURL Version: 7.64.0
    OpenSSL Version: OpenSSL/1.1.1d
    OS: Linux wp490 4.14.132-xenu-he #1 SMP Fri Dec 13 09:08:45 UTC 2019 x86_64
    PHP: Linux 7.4.14-he.0 en_US.UTF-8
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=No, mcrypt=No, zlib_encode=Yes
    WordPress: 5.7.2 de_DE UTF-8
    WordPress Theme: Shop Isle
    WordPress Plugins: Antispam Bee, ARI Adminer, BackWPup, Cachify, Classic Editor, Disable Comments, Dynamic Pricing and Discounts for WooCommerce Basic Version, Heartbeat Control by WP Rocket, Local Fonts, VarkTech Minimum Purchase for WooCommerce, Popup by Supsystic, Post SMTP, Products Purchase Limit for WooCommerce, Simple History, Statify, Sucuri Security – Auditing, Malware Scanner and Hardening, Ultimate Member, PayPal PLUS for WooCommerce, WooCommerce Advanced Free Shipping, WooCommerce PayPal Checkout Gateway, Germanized for WooCommerce, WooCommerce PDF Invoices & Packing Slips, WooCommerce, Yoast SEO, WPFront Notification Bar, YITH WooCommerce Custom Order Status
    WordPress wp_mail Owner: /is/htdocs/wp10676469_0PVIUEJYNU/www/woo/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, WPO\WC\PDF_Invoices\Main->set_phpmailer_validator, PostsmtpMailer->get_mail_args
    WordPress phpmailer_init Action(s): PostsmtpMailer->phpmailer_smtp_init
    Postman: 2.0.23
    Postman Sender Domain (Envelope|Message): mydomain.com | mydomain.com
    Postman Prevent Message Sender Override (Email|Name): No | No
    Postman Active Transport: SMTP (smtp:tls:plain://wp10676469.mailout.server-he.de:587)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 23 | 64
    Postman File Locking (Enabled|Temp Dir): No | /tmp`

    Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    You could try swapping the authentication from ‘Plain’ to ‘Login’. Otherwise, you need to speak with your hosting provider about this error as their SMTP server is throwing it.

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    OK, thanks…I changed that. Now I’ll wait and see what happens…

    Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    Okay, great. Do test emails send okay?

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    Just checked. Test emails are ok, but there was just on e email that returned the same error.

    In the setting “Envelope Sender email address” we have “shop@ourshop.eu”, and this is the account for the Authentication Data.

    Ther Error says “You are not allowed to use the domain web.de as DATA From domain.”

    This is a different address/domain. I believe it comes from WooCommerce’s mail settings, there is this address “shopowner@web.de” (the shop owner’s private address” in the FROM field.

    Maybe the Postman Settings take this address for his FROM, this would explain the error.

    Would there be a possibility to change the FROM only in Postman, from shopowner@web.de to shop@ourshop.eu?

    Thanks!

    Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    You must send as the user you are authenticating as.

    If you are authenticating as shopowner@web.de, you should set your envelope-from to shopowner@web.de too.

    You should not “spoof” an address by changing the envelope-from in Post SMTP – this will lead to many deliverability issues.

    Check out SPF, you will face issues with that too.

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    This makes sense, thank you.

    (Strange that without using Postman this was never an issue…)

    …I will check that…

    Plugin Support Tim

    (@tneville)

    Okay, please let us know how you get on.

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    Helo,

    that was the solution. We changed the FROM Address to become the same as with which SMTP Postman logged on…and then it worked.

    Thanks a lot!

    Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    No problem, it is really important to do that to get the best deliverability. šŸ™‚

    Kind Regards,
    Tim

    Thread Starter Gerdski

    (@gerdski)

    It has worked šŸ™‚

    (I just wonder why things were competely different without your plugin…ordinary mails were fine, but the Backup Plugin could not send a mail, that’s why we installed your plugin…)

    Plugin Support Tim

    (@tneville)

    Hi @gerdski,

    That is strange, as I say, it’s not normal practice to set it up your original way anyway – but glad all is okay now.

    Kind Regards,
    Tim

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.