Support » Plugin: Edwiser Bridge - WordPress Moodle LMS Integration » “Exception Class ‘webservice’ not found” error on Moodle configuration page

  • Resolved edmyn

    (@edmyn)


    In /local/edwiserbridge/edwiserbridge.php?tab=service there is now an error message that says:

    Exception – Class ‘webservice’ not found
    More information about this error

    In debug mode there is also the following messages:

    Debug info:
    Error code: generalexceptionmessage

    Stack trace:
    line 466 of /local/edwiserbridge/mod_form.php: Error thrown
    line 204 of /lib/formslib.php: call to edwiserbridge_summary_form->definition()
    line 103 of /local/edwiserbridge/edwiserbridge.php: call to moodleform->__construct()

    The Moodle version we use is 3.5.17. Local_edwiserbridge version is 2.0.6. Auth_wdmwpmoodle version is 1.3.9.

    We also have a Moodle installation in version 3.9.5 with the same plugin version installed, and these error messages do not show there.

    Does this mean that Edwiser Bridge is not compatible with Moodle 3.5?

    Best regards,
    Edmyn

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @wisdmlabs I’ve deleted your offer to login to your user’s site. While I know you have the best of intentions, it’s forum policy that you not ask users for admin or server access. Users on the forums aren’t your customers, they’re your open source collaborators, and requesting that kind of access can put you and them at high risk.

    If they are paying customers (such as people who bought a premium service/product from you) then by all means, direct them to your official customer support system. But in all other cases, you need to help them here on the forums.

    Thankfully are other ways to get information you need:

    You get the idea.

    We know volunteer support is not easy, and this guideline can feel needlessly restrictive. It’s actually there to protect you as much as end users. Should their site be hacked or have any issues after you accessed it, you could be held legally liable for damages. In addition, it’s difficult for end users to know the difference between helpful developers and people with malicious intentions. Because of that, we rely on plugin developers and long-standing volunteers (like you) to help us and uphold this particular guideline.

    When you help users here and in public, you also help the next person with the same problem. They’ll be able to read the debugging and solution and educate themselves.

    Plugin Author WisdmLabs

    (@wisdmlabs)

    Hello @edmyn

    Thank you for bringing this to our attention. Edwiser Bridge is compatible with Moodle 3.5!

    Could you please add the following line to the code in the file local/edwiserbridge/mod_form.php on line 168

    if( ! class_exists(webservice)){
    require_once $CFG->dirroot.”/webservice/lib.php”;
    }

    It is before the following line
    $webservicemanager = new webservice();

    We believe it will resolve the issue. If the issue persists please let us know.

    Thanks,
    Dharmesh Barot
    Team Edwiser

    • This reply was modified 2 months, 2 weeks ago by WisdmLabs.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.