• Resolved MarkRR

    (@markrr)


    I get this message – Sorry, there was a YouTube API error: The request cannot be completed because you have exceeded your quota.

    I have the YouTube API key installed correctly.

    I don’t get much traffic to this site at all.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having a similar issue.

    I have a small site (www.captmacs.com) with ~20 videos that used to display. Now I permanently get the following error:

    “Sorry, there was a YouTube API error: The request cannot be completed because you have exceeded your quota. Please make sure you performed the steps in this video to create and save a proper server API key.”

    I’ve regenerated the API key, I’ve created a new one from scratch. And I’ve followed the instructions to the tee. There’s nothing else that is using this API key.

    • This reply was modified 1 year, 10 months ago by btemp.
    Plugin Author embedplus

    (@embedplus)

    You may want to try turning on caching — either within the plugin or a separate caching plugin.

    LMP

    (@loizos16673)

    Can you please explain what you mean “turning caching on” within the plugin?

    There does not appear to be any chache on/off option in the plugin settings.

    Where is it?

    LMP

    (@loizos16673)

    OK, I figured out that the free version of this plugin does not support caching.

    I don’t know what caused the issue in the first place, but the Queries per day value for the YouTube Data API v3 was zero. That’s why I was getting this exceeded quota error.

    I also figured out how to fix the issue:

    1. Go to Google Developer site, and delete the current project
    2. Create a new project with the same parameters (YouTube API, permissions, etc.)
    3. Put the new API key in the plugin settings.

    The new project should have the correct Queries per day value.

    I wonder if the plugin caused the Queries per day value to be broken, or if it was something on the Google server. In any case, I switched to another WordPress YouTube plugin that supports caching for free. I hope this will stop the issue from reappearing.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Exceeded Quota Error’ is closed to new replies.