Support » Plugin: EWWW Image Optimizer » EWWW Image Optimizer & PHP 5.4.45

  • Resolved Lúa Louro

    (@orballa)


    Hi!

    I have this message when I activate the plugin:

    EWWW Image Optimizer requires exec() or an API key. Your system administrator has disabled the exec() function, ask them to enable it.

    My website’s client has PHP 5.4.45, maybe it’s the reason. I have talked with her hosting to update the PHP version, so I hope fix the problem.

    Is this the right way?
    Thanks

Viewing 1 replies (of 1 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    If your client’s webhost has disabled exec(), it is unlikely upgrading PHP will do anything. But they really should upgrade that anyway, 5.4 is ancient 🙂

    If the client has a custom php.ini, make sure that it isn’t disabled there, it would be in the disable_functions setting.

    If you can’t get around it any other way, and the webhost won’t enable exec(), your use case is exactly why I created the API service: https://ewww.io/about/

Viewing 1 replies (of 1 total)
  • The topic ‘EWWW Image Optimizer & PHP 5.4.45’ is closed to new replies.