Support » Plugin: EWWW Image Optimizer » EWWW Image Optimizer could not install tools in…

  • Resolved MPStranger



    I installed v 3.7 and had some error. Then I added this in my php.ini:


    And it all worked fine for about 10 days.

    Now I get this error message (with v. 3.7.1):

    EWWW Image Optimizer could not install tools in /…/ewww/. Please adjust permissions or create the folder. If you have installed the tools elsewhere on your system, check the option to Use System Paths. For more details, visit the Settings Page or the Installation Instructions.

    EWWW Image Optimizer requires jpegtran, optipng or pngout, and gifsicle. You are missing: optipng, gifsicle. Please install via the Settings Page or the Installation Instructions.

    This error did not come right away after updating to the newest version – it sort of came out of the blue.

    I am on a shared hosting.

    Here’s my Plugin status:

    And my Debug Log:

    Hope you can help me out – cuz I love this plugin 🙂

    Although I do not have access to SSH, so it might be a bit difficult?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author nosilver4u


    If you didn’t do anything to cause this error, then perhaps your webhost did. From looking at the debug log, someone replaced the files jpegtran & optipng with some sort of dummy file, removed gifsicle, and then set permissions on the wp-content/ewww/ folder so it couldn’t be written to.

    The appropriate way to fix it is to remove everything in the wp-content/ewww/ folder and set permissions on that folder to 755. I think you can do that via normal ftp software, or you can ask your webhost to do it for you.



    I also receive this message, but have one additional thing to add:

    Immediately after updating to version 1.7.3, I received an email from my hosting that indicated this:

    Our systems performed a routine malware/virus scan on your account and unfortunately located infected/malicious files. We’ve automatically moved the infected files(s) out of your public_html directory into a safe, quarantined directory. Below is the file our scanners were able to locate:

    [cut out path location]/ewww-image-optimizer.tmp/ewww-image-optimizer/optipng-linux ClamAV detected virus = [Heuristics.Broken.Executable]

    My hosting thinks there is a virus in this file. Perhaps that is what happened in MPStranger’s case as well.

    Is there a virus in this file? What should I do now?

    Plugin Author nosilver4u


    No, there are no viruses, just ran a scan myself with clamav to make sure it wasn’t flagging something improperly.

    Your host has the ‘broken executable’ option turned on, which isn’t very useful. I can’t say for sure why it would trigger on your webserver, when it runs clean on mine, unless you manually uploaded the plugin via ftp or something of that nature. Binary files (executables) are a bit picky though, and cannot be transferred in normal ascii mode via ftp, they have to be transferred in binary mode, or you will more than likely get ‘broken executables’.

    What I would do, is deactivate the plugin, delete it, and then reinstall using the built-in plugin installer in wordpress.



    Deactivate, delete, and reinstall seems to have corrected the problem. So far, no error messages and no emails from my hosting company.

    I only ever installed and updated through the official WP plugin area, so not sure what happened. But at least it seems OK now.

    Thank you for your prompt assistance.

    Well that did not work for me.

    You say jpegtran & optipng was replaced by dummy-files? Is it the plugin that would add these files? When I look in the ewww folder there is nothing and I have even tried to change the write-setting to: (777)

    I’ve tried to trick it by copying these files from another ftp with this plugin installed:

    What happens is that somehow the files gets deleted as soon as I do anything in my admin area. That seems pretty strange?

    I have noticed that in fact all files without any extension will disappear from my server right away. I have contacted my host regarding this…

    Currently I suspect that my host is auto deleting them for being executable and potential dangerous files… But I’ll tell you what they come back with.

    Ok, so they have told me that they will not allow Linux Binary/Executable files.

    So I guess that’s it for me with this plugin.

    Plugin Author nosilver4u


    That was kind of my suspicion from looking at your debug log, that your webhost had removed the files and replaced them with ‘placeholders’. Let us know what you find out, and if you can, who your webhost is.

    I Use a Danish Host and on their shared hosting I am not able to use this plugin as they do not allow Linux Binary/Executable files. However, on their Pro-version (still shared, but fewer domains per server) I do not have this problem. So for now I can only use this on their overpriced PRO-version which is a pity.

    The weird thing is that it did actually work for about ten days. I have more than one profile with them and have tried to install it on another server, but it is not working. When uploading the plugin I only see 18 files within the plugin\ewww…. (of 29 in total) and in content\ewww all the files are gone.

    It is still working on my Pro-version and I am not going to give them any good ideas 🙂

    So even though I cannot get this to work, I consider it resolved. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘EWWW Image Optimizer could not install tools in…’ is closed to new replies.