Support » Plugin: S3 Video Plugin » everything working, but no audio using S3 Video Plugin

  • Resolved LoCostMarketing


    Hi there,

    I’m going through the painful task of working out how to embed Amazon S3 videos into WordPress, which is a amazingly complicated for what should be a simple process (takes 2 seconds in YouTube).

    After installing the S3 Video Plugin I worked out how to sync with Amazon S3 and pull out either the embed code or the short code.

    The video works perfectly but there is no audio. But when watching a preview of the video inside the Existing S3 Videos page – it works with audio.

    I have tried switching between VideoJS and Flowplayer but the same thing happens.

    Any suggestions please?


Viewing 8 replies - 1 through 8 (of 8 total)
  • I figured it out.

    Sorry false alarm.

    @locostmarketing Wouldn’t this post be more meaningful and helpful if you had described how you resolved your problem? Others may be having the same problem and your solution could save them time and aggravation.

    I am having the exact same problem. Can you please post how you resolved?

    From memory I had to go to the dashboard in Amazon S3 and right click on the files and then choose “Make Public”

    The link for my dashboard is but it may be a little different for you

    I’m pretty sure it was as simple as that, but they never mentioned it anywhere, I just tried that as a guess and it worked

    Thank you for the help. Unfortunately, that did not work for me. I am embedding the code as this: [s3mv]videos/assessment/,550,450,false,false[/s3mv]

    Do you know if there’s anything from here? I also tried true, true where the falses are and had the same issue.

    I’m not using the plugin anymore but from memory you will need to convert all your videos to the .mp4 format and the shortcode should look like this:

    [S3_embed_video file=’Module01.mp4′]

    Just replace Module.mp4 with your file name. Originally I was using files that were .mov and created with my Mac, but it didn’t recognise QuickTime files and I read somewhere that you should convert them to .mp4.

    And the other thing is to switch between the Flowplayer option and the VideoJS options in the Plugin Settings. And also make sure all files as set as “Public” as described above.

    Good luck.

    Okay great, I will try all of that. Thanks again for the help!

    Plugin Author Anthony Mills


    Hi Smartmoves,
    LoCostmarketing is correct the video needs to be encoded in a “web friendly” format. .mov and .mp4 are just containers both can be used although your mileage may vary depending on what codecs are used within.



Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘everything working, but no audio using S3 Video Plugin’ is closed to new replies.