Support » Fixing WordPress » Everything leads to a critical error

  • Hi guys, I am getting a critical error on my site and nothing so far has helped.

    • the login and dashboard are inaccessible
    • I’ve tried reinstalling wordpress through ftp
    • Debug and debug_log do nothing. logging to a file doesn’t do anything either
    • I’ve renamed the plugin and theme folders and it doesn’t do anything
    • the recovery link (/wp-login.php?action=entered_recovery_mode) does not work
    • I don’t get any email for the recovery link with a token

      I think this was caused by the latest php update but I can’t be sure. the host I’m on won’t let the version go back further than 8
    • This topic was modified 1 week, 1 day ago by chrisdarkm.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Michael

    (@michaelvdberg)

    Did you tried already to enable the WP_Debug already in your wp-config.php file in the root of your webserver (where WordPress is installed)? If you did, are you using also a caching plug-in? In that case you could delete the cache files and rename the caching plug-in temporary by going to the plugins folder in wp-content. Mostly there should shown some WordPress error logs.

    Otherwise it should be server related. I know on another WordPress website with a premium theme that there is an issue with the PHP 8.1, but with PHP 8.0.x are no errors. Did you tried that as well?

    If you have access to your webserver folder public_html or private_html (depending on your set-up), you can create or use the .htaccess file. Sometimes it works to set the PHP version back to an older version. You can try this with the following code below. You can change the 71 to the version you prefer on the second row. For instance php74 will use the php 7.4 and 71 the php 7.1

    <FilesMatch "\.(php4|php5|php3|php2|php|phtml)$">
    SetHandler application/x-lsphp71
    </FilesMatch>

    If this doesn’t work you can read the article of Kinsta about this error. But to be sure. Your WordPress, themes and plug-ins are up-to-date?

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.