WordPress.org

Support

Support » Plugins and Hacks » everything is broke

everything is broke

  • I just updated to the latest version and when I now try and go to the WordPress backend I get the following error:

    Fatal error : Uncaught exception 'FileOperationException' with message '/home/kevi7793/public_html/RefuGeeks/wp-content/w3tc-config/master.php could not be created, please run following command:
    chmod 777 /home/kevi7793/public_html/RefuGeeks/wp-content/w3tc-config' in /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/activation.php:117 Stack trace: #0 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error('/home/kevi7793/...') #1 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(421): W3_ConfigWriter->save() #2 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/update.php(58): W3_ConfigWriter->import_legacy_config_and_save() #3 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php(298): w3_run_legacy_update() #4 /home/kevi7793/public in /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 117

    I’ve reset the permissions to the whole w3-cache folder to 777 and I’m still getting this error. My site is still up but I currently can’t manage a thing at the back end. This is very urgent.

    Thanks

    Kev

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Fixed it.

    Had to manually uploade a blank “master.php” file to /wp-content/w3tc-config/

    Not good though guys, I’d expect this kind of error to be tested before pushing an update. 🙁

    Plugin Author Frederick Townes

    @fredericktownes

    You’re right. This release has been used with customers and testers for over a year. Bugs happen, thanks for using W3TC. Another release is coming out today, sorry.

    Frederick Townes wrote:

    Another release is coming out today, sorry.

    W3 Total Cache 0.9.2.7? :eek

    @frederick Lot of stuff going on, I know. Some plugins I wait to update after initial release. Especially after the last major change with yours. I give yo credit for what you do with it. Kudos

    No harm done, I just got panicked when nothing worked 🙂

    All fixed now – excellent plugin that I’d be lost without.

    Thanks guys.

    Glad I found this. Great plugin and looking forward for the new release. I just encountered the same lovely message and the back end is completely inaccessible. Not a coder so any advice on which files should be deleted from the cPanel or any fix would be much appreciated. Thanks much in advance.

    Do you have FTP access to you server?

    If so, create a blank file and call it “master.php” (without quotes). Then, upload this file to your wordpress site in /wp-content/w3tc-config/

    So, to be clear, if your site is called abc.com you will probably have a folder on your server called abc or abc.com. Go into that folder, then wp-content, then w3tc-config and upload the master.php file there.

    Refresh and all should be ok 🙂

    Kev

    Thanks so much Kev! Worked like a charm.

    Hi there,

    I have the same problem…on two sites…
    A blank page after the login…..

    I tried this:

    Had to manually uploade a blank “master.php” file to /wp-content/w3tc-config/

    But nothing happens after that….
    What can I do to fix it?
    No programmer or hard core wordpresser here…:-(….

    Thanks in advance!!!
    K.

    GPSuhrTest:

    I had to refresh a couple of times. Hopefully that will help.

    Have you definitely made the file extension .php? If you’ve done it in Windows then there is a likelihood that there is another file extension. For example, if you created it in Notepad then the file is probably called master.php.txt.

    I’d double check that first…

    ????????????

    Did I miss something ? What is broken ? It runs great on my site … but I can confirm that it slows a little bit the site. For the rest I have no errors or bugs with this plugin

    I Kev and Silvia,

    thanks for your replies.

    Kev,
    I put it here /plugins/w3-total-cache/wp-content/w3tc
    is that correct? I couldn’t find a “w3tc-config/” like you wrote and I used Taco for Mac to generate the .php file…
    I try again now:-)…

    Sylvia,
    just refresh the browser again and again?

    Thanks and cheers from Hamburg!
    K.

    Here is another file called wp-content/w3tc/min

    should I put the master.php into the /min maybe??
    Nothing works when I put it into the /w3tc and I don’t have a “w3tc-config/” where you put it, Kev…

    Hmmmm….

    Can I just delete it from the server or what can I make to let my page run again?
    Site it available but the backend not….:-((((

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘everything is broke’ is closed to new replies.