Support » Installing WordPress » Everything “fails” — can’t edit, activate/deactivate plugins, etc.

  • Resolved mikokagome04


    Hello, everyone. I just upgraded from WP 2.6.2 to 2.7, and logged back into my blog as an administrator to reactivate my plugins. To my surprise and consternation, I found that I couldn’t reactivate any of them! Clicking the “Activate” link only yields the message

    Your attempt to activate this plugin: “[plugin name]” has failed.

    Please try again.

    I tried doing other things, like editing posts and changing the theme, and all other actions, if you can believe it, yield the exact same “fail” message.

    Now, I rechecked my file permissions (all set to 755), and my upgrade seems to have gone OK apart from this unfortunate problem. Any thoughts/solutions?

    By the way, my blog URL is, if that helps any.

    And as another note, I just updated the contents of my wp-config.php today; previously I did my upgrades by reuploading everything except for the wp-config-sample.php, which I realized contained some changes since version 2.2 or whatever. I estimate that the last version of the file I used was from before 2.2, possibly.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I would first check to ensure all the files uploaded. My guess is that something in the new source code didn’t make it.

    According to my FTP client, all the files did make it, but I’ll reupload everything just to make sure.

    If all the files made it, your plugins are deactivated, (I assume you deactivated them before upgrading?), and it actually upgraded the db, then I’m at a loss…maybe someone else has some ideas. Sorry.

    Yeah, my FTP client just finished reuploading everything. Thanks for the tip, figaro. Still have no clue what’s going on, though.

    Anyone else? Your assistance would be greatly appreciated. @_@

    An outside chance, but since you said you created a new config.php file, you may want to make sure you have a copy of that file and then delete it and upload your original config file.

    I just tried that, figaro, except that it still doesn’t work. T___T

    Okay, I’ll leave it for someone else to try to help you. If you don’t get it fixed by tomorrow and want to me to take a look just leave a way for me to contact you. Don’t do it now or the mods will close the thread and there may still be someone who can help you here.

    I’m pretty good at figuring things our when I can look under the hood and poke around 🙂

    Thanks a bunch, figaro! I’ll gladly take up your offer should that happen.

    So… does anyone else have an idea? All the files are uploaded, permissions set to 755, and the wp-config.php file doesn’t seem to be the problem…

    Just an update… I tried changing some general blog settings via the admin panel, except when I go to click the “Save Changes” button, I get this message:

    Are you sure you want to do this?

    Please try again.

    Haha! A funny thing to say, isn’t it? Passing over the fact that my blog is practically disabled, of course…

    Commenting (and deleting comments) seem to work…

    I don’t know what the heck happened, but I checked back with my blog a few minutes ago, and I’m able to edit posts/pages and activate my plugins again. That is really weird; I didn’t make any more changes/desperate attempts at fixing the problem. But oh well. Thanks so much for the help, figaro. It was probably just a temporary server error. If the problem resurfaces, I’ll be sure to give you a call. ^____^

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Everything “fails” — can’t edit, activate/deactivate plugins, etc.’ is closed to new replies.