WordPress.org

Forums

Subscribe2
"every week seconds" (12 posts)

  1. My settings page displays "Every week seconds" rather than just "Every Week"

    http://i.imgur.com/STM3eZh.png

    Looks like its in readygraph-extension.php, line 100

    https://wordpress.org/plugins/subscribe2/

  2. CA Clarion
    Member
    Posted 1 year ago #

    I'm having the same issue. It happened after I upgraded the plugin but had not activated ReadyGraph yet.

  3. tanaylakhani
    Member
    Plugin Author

    Posted 1 year ago #

    noted. and will be committed in next update. That is a typographical error.

  4. CA Clarion
    Member
    Posted 1 year ago #

    Is there a way to custom edit the subject line on the digest in the free plugin? When will the next update occur? Our blog digests can not go out to our members this way.

  5. CA Clarion - please create your own support thread, as that question is not related to this thread at all.

    (Or, consider browsing through the various tabs on the Subscribe2 Settings page.)

  6. CA Clarion
    Member
    Posted 1 year ago #

    Jason they are actually very related because if you send a weekly digest email it uses the "Every Week Seconds" setting description on the settings page that you are referencing above, as the subject line of the digest email. The problem appears to a bit bigger than a simple typo on a settings page. It is visible to subscribers. Sorry if I wasn't more clear.

  7. tanaylakhani
    Member
    Plugin Author

    Posted 1 year ago #

    okay. you can correct it by editing /subscribe2/readygraph-extension.php file: line 61

  8. tanaylakhani
    Member
    Plugin Author

    Posted 1 year ago #

    It will be committed in next update

  9. > Is there a way to custom edit the subject line on the digest in the free plugin?

    Settings -> Templates provides boxes to enter the subject line that you want.

    How are you getting 'Every Week Seconds' displayed to your subscribers anywhere?

  10. CA Clarion
    Member
    Posted 1 year ago #

    Exactly Jason. I have the subject I want entered in the Templates section, but it seems this bug in the most recent update is overriding it and using the "Every Week Seconds" as the subject line INSTEAD of what I have entered in the Templates settings.

  11. mattyrob
    Member
    Posted 1 year ago #

    @CA Clarion,

    The apparent issue with the email subject is nothing new and it's by design, the template heading is not used for digest emails.

    You can set your own custom subject using the API, in particular the 's2_email_subject' hook which is documented on that linked page.

  12. CA Clarion - apologies for misunderstanding. The wonder Mattyrob's suggestion of the filter should get you squared away if you want to fix the wording without modifying the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Subscribe2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

  • RSS feed for this topic
  • Started 1 year ago by Jason Lemahieu (MadtownLems)
  • Latest reply from Jason Lemahieu (MadtownLems)
  • This topic is not resolved
  • WordPress version: 3.9.1

Tags

No tags yet.