Support » Themes and Templates » Every theme fails!

Every theme fails!

  • I’m trying to use a theme called “Comicpress.” But when I activate Comicpress, none of the layout/positioning information seems to work. All the page elements appear stacked up along the left edge of the page. The fonts all default to an ugly TimesRoman, as well. When I couldn’t get that to work, I tried several other themes instead, and they all did the same thing. Eventually, when I went back to the “Twenty-Ten” theme I’d been using previously, it, too, had apparently lost all its layout/positioning information, and everything was stacked up on the left. I tried re-installing WordPress, but nothing changed. I don’t know how to write code, so the only thing I can think of to do is to try to delete all the WP files and re-install. I’ve tried this once already, and screwed it up, so I’m afraid to try it again. Can anybody offer me a better plan?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Can you please post a link to your site? I just answered a similar question on another thread, and the problem seems to be a file permission issue with the style.css file.

    Here’s the URL: crylock.net

    Thanks for responding, Bruin! Here’s the URL of my site:


    Yes, there’s something strange going on. When I try to look at the style.css file, I get a number of errors that look like the CSS file is being handled like a script:

    Internal Server Error
    Script Error:
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 1: /bin: is a directory
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 2: Theme: command not found
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 3: Contributors:: command not found
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 4: Theme: command not found
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 5: Description:: command not found
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 6: syntax error near unexpected token ('
    /www/cgi/wp/wp-content/themes/comicpress/style.css: line 6: Author: Philip M. Hofer (Frumph)
    Exited with (2) from signal (0)

    Did you happen to make any CHMOD changes to your files, or make any changes to .htaccess? Did you recently move your site under the CGI folder?

    I have no explanation that I would understand. 🙂 I built my site using Dreamweaver, but I don’t know the first thing about CSS and have never opened that file.

    I’ve had an html frontpage with a WordPress blog on a back page for 3 years, and recently decided to try to adapt my WordPress blog to make a new frontpage. Without moving its location, I tried to install the Comicpress theme, along with all the plugins that theme’s creator recommended. That’s when this formatting issue occurred.

    I removed the plugins, tried several other themes, and re-installed WordPress, but nothing worked. Finally I deleted all the WordPress files (completely failing to save the config.php file first), and then tried to re-install WordPress, this time allowing it to take the frontpage (index) position. It didn’t work, since I had no config information, and I had to ask my host server’s tech support for help. They restored WordPress from an earlier date, complete with the same formatting issue. Which brings us to now.

    Could any of that account for there being erroneous code in my CSS file? And more importantly, how can I fix it?

    I really appreciate your taking time to help me with this! I’ve been floundering here for almost two weeks!

    Not sure whether this is exactly what you meant, but here’s the top few lines…

    Theme Name: ComicPress
    Contributors: Frumph
    Theme URI: http://frumph.net/comicpress
    Description: Publish a WebComic with the ComicPress theme and the Comic Easel plugin.
    Author: Philip M. Hofer (Frumph)
    Author URI: http://frumph.net
    Tags: two-columns, three-columns, left-sidebar, right-sidebar, fixed-width, custom-background, custom-header, custom-menu, theme-options, threaded-comments, sticky-post, translation-ready, flexible-header, featured-images
    Version: 4.1
    License: GNU General Public License, v3 (or newer)
    License URI: http://www.opensource.org/licenses/gpl-3.0.html


    html {
    overflow-y: scroll;

    body {
    margin: 0;
    font-family: ‘Arial’, sans-serif;
    font-size: 14px;
    color: #000;

    a {
    text-decoration: none;

    a:link {
    color: #b00;

    a:visited {
    color: #600;

    a:hover {
    color: #f00;

    a:focus {
    outline: none;

    a img {
    border: none;

    p {
    margin: 0;
    padding: 5px 0;

    p.attachment {
    text-align: center;

    img {
    padding: 0;
    margin: 0;

    .entry img, .post-content img {
    max-width: 100%;
    height: auto;

    small {
    font-size: 12px;

    hr {
    height: 1px;
    color: #000;
    background-color: #000;
    border: 0px;

    blockquote {
    margin: 5px;
    border: 1px dashed #ccc;
    padding: 0;
    font-size: 11px;
    font-weight: 400;

    blockquote p:first-letter {
    float: left;
    font-size: 16px;
    font-weight: 700;
    margin: 3px 2px 0;

    blockquote p:first-line {
    font-variant: small-caps;

    acronym, abbr, span.caps {
    cursor: help;

    acronym, abbr {
    border-bottom: 1px dashed #000;

    form {
    margin: 0;

    input, textarea {
    font-family: ‘Arial’ , sans-serif;
    font-size: 13px;

    /* WP Aligns */

    .aligncenter {
    margin: 0 auto;
    text-align: center;
    display: block;

    .alignright {
    margin: 10px 0 10px 10px;
    display: inline;
    float: right;

    .alignleft {
    margin: 10px 10px 10px 0;
    display: inline;
    float: left;

    .wp-caption {
    text-align: center;
    padding: 3px;
    background: #eee;

    Sorry I didn’t reply earlier, I’ve been busy on a couple of projects. It looks like you’ve reverted back to a non-WP design on your main page. I was going to say that it’s probably not a CSS problem, since you said that it happens with every theme that you’ve tried, but it looks like you have it running here under TwentyTen. Was it a file permissions issue? Does ComicPress still not work?

    Hey, thanks for getting back to me! Obi-Wan, you’re my only hope! I returned the site to my original front page so my readers don’t give up on me (Been messing around with this for 2 weeks!). But I’m still trying to find a way to make WordPress work, or alternatively find some other way to get a blog and a comic-reader onto my front page.

    I’ve learned that the Twenty-Ten theme, the one I’ve been using for 3 years, is the only theme I can use. Every other theme I’ve sampled (with a live preview from the dashboard) appears smoosh-left. I can’t even update Twenty-Ten without losing all formatting.

    I’ve been fooling around with the plug-in Comic Easel, trying to insert the features I need into Twenty-Ten, but so far they just don’t seem to register. Desperation is starting to set in…

    I’m going to try once again to uninstall and re-install WP. This time I have it all backed up locally. Wish me luck!

    No luck. I removed all the WP files I could, and re-named the folder where the ones that remained lived. Then I tried to do a clean install of WP using Freeservers’ automated install. I fed in the info from the original wp_config.php file when it asked for it. But all I got were these errors:

    Error establishing a database connection

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Every theme fails!’ is closed to new replies.