Support » Plugins and Hacks » Every search produces "No results"

Every search produces "No results"

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ajay


    Hi, I can see search results for methodology


    I can’t explain it. I deactivated the plug in, tried another search enhancer, and gave up on it. Reactivated Better Search for a second time, and this time it stayed working. Bizarre.

    BTW – I did find these errors while it wasn’t working.

    [Fri Apr 04 02:23:42 2014] [error] [client] WordPress database error The used table type doesn’t support FULLTEXT indexes for query SELECT ID, (MATCH(post_title) AGAINST (‘Methodology’ IN BOOLEAN MODE ) * 1 ) + (MATCH(post_content) AGAINST (‘Methodology’ IN BOOLEAN MODE) * 3 ) AS score FROM wp_posts WHERE MATCH (post_title,post_content) AGAINST (‘Methodology’ IN BOOLEAN MODE) AND post_status = ‘publish’ AND ( post_type = ‘post’ OR post_type = ‘page’ OR post_type = ‘product’ OR post_type = ‘event’ OR post_type = ‘testimonial’ ) ORDER BY score DESC /* From [280group.com/?s=Methodology&post_type=product&submit=Search] in [/nas/wp/www/cluster-1359/main280website/wp-content/plugins/better-search/better-search.php:323] */ made by require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), call_user_func_array, bsearch_template_redirect, include_once(‘/themes/280GroupCanvas-Child/better-search-template.php’), get_bsearch_results, get_bsearch_matches, referer: http://280group.com/product-management-methodology/

    Plugin Author Ajay


    I have a feeling this could be because your tables are in InnoDB in a version below 5.6 which doesn’t support FULLTEXT indices.

    If your table is in ISAM then it would support the FULLTEXT. Unfortunately, it’s an issue that I haven’t found a solution to. 🙁


    Now search is broken again. Every search produces “no results.”

    How is it that it works, but then completely fails?

    The site is hosted at WPEngine. Is there some problem with that environment? I was working fine during development. Now that it’s in production, I enabled the CDN.

    My only guess is somehow their caching environment is effecting Better Search.

    Plugin Author Ajay


    Jim, it could be a possible that it’s the WP Engine environment. I know that they don’t like FULLTEXT indices and so they might be automatically cleaning up these which could also explain your error above.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Every search produces "No results"’ is closed to new replies.