Support » Plugin: UpdraftPlus WordPress Backup Plugin » Every backup takes 8 hours to complete

  • Resolved cag8f

    (@cag8f)


    Hello. I use your plugin on several different sites. It is very easy to use and typically has no issues. But on one of my sites I am experiencing an issue. Whenever I carry out a backup, it takes ~8 hours to complete. During that time, my site goes down several times with an HTTP Error 500 message. Can you help me troubleshoot this?

    Here is some more info:

    • I am using the latest version of the plugin (v1.16.0), and the latest version of WordPress (5.02).
    • The total size of the ZIP files in the backup is ~500 MB. This is a bit large, but shouldn’t be causing the issue I’m seeing.
    • In the UpDraftPlus log file are several timeouts/jumps in time stamp. But the log doesn’t seem to indicate the cause of those timeouts. There is one error entry that appears several times: “16105.342 (5) Binary zip: error (code: 9 – look it up in the Diagnostics section of the zip manual at http://infozip.sourceforge.net/FAQ.html#error-codes for interpretation… and also check that your hosting account quota is not full).” I can send you the full UpDraftPlus log file for your review. But can you confirm that it does not contain sensitive information? If it does not contain sensitive info, I can post a link here. If not, I’ll need a secure place to send it.
    • I have PHP logging enabled, but there are no entries written to the PHP log during this time.
    • As soon as I begin the backup, a few of my server stats jump from zero to max levels (screenshot). Specifically, “Physical Memory Usage” jumps from 0 to its max of 256 MB, and “I/O Usage” jumps from 0 to its max of 1 MB/s. They remain at max levels for essentially the entire 7 hour backup (screenshot).
    • I also experience a timeout whenever I try to update the plugin. To be clear, an error occurs (screenshot; full error message here). But when I refresh the Plugins page, the plugin appears to have updated. Not sure if that’s related.
    • I should also say that I can also replicate this timeout/HTTP Error 500 issue with other tasks. Notably, if I initiate a security scan using the Wordfence plugin, a very similar issue occurs (although it doesn’t last for 8 hours–it times out and fails rather quickly). And when I run a SiteCheck on my site from the Sucurit website, it also times out. Could be related to the backup issue, and all caused by my limited server resources, or not. But just throwing this out there for the best analysis of the situation.

      Thanks.

    • This topic was modified 3 months, 4 weeks ago by  cag8f.
    • This topic was modified 3 months, 4 weeks ago by  cag8f.
    • This topic was modified 3 months, 4 weeks ago by  cag8f.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Support bornforphp

    (@bornforphp)

    Hi,

    Could you try to reduce the backup archive split size. This will split the backup into smaller, more manageable files.

    To do this, open the ‘expert settings’ section of the UpdraftPlus Settings tab, and find the ‘split backups every’ option. Set this to lower value save your settings and run a new process.

    If the issue persists, please ask your hosts/server admin to investigate their PHP error logs. These logs should contain more information on the exact issue that is causing the backup process to halt.

    Thanks,
    Harshad

    Hi Harshad,

    OK thanks for that suggestion. Give me a day or two and I’ll lower the ‘split backups every’ option from 400 MB to 100 MB. I will also enable ‘debug mode’ and initiate another scan. I will report back here.

    >> If the issue persists, please ask your hosts/server admin to investigate their PHP error logs. These logs should contain more information on the exact issue that is causing the backup process to halt.

    As I mentioned, I have already checked the PHP error logs, before and after the backup. There are no new entries written.

    Thanks.

    Plugin Support bornforphp

    (@bornforphp)

    Hi,

    Sure! Do let us know how it goes.

    OK I lowered the ‘split backups every’ option from 400 MB to 100 MB. I also enabled ‘debug mode’ in Settings–>Updraft Plus Backups–>Settings. I then initiated another backup.

    • This time the backup lasted 6 hours instead of 8 hours.
    • In the log file is the same same “Binary zip: error (code: 9” error–11 times.
    • There are no entries written to the PHP log during this time.
    • During the backup, certain server stats again jumped from zero to max levels, and remained that way for the duration of the backup, resulting in my site going down several times (HTTP Error 500). Even downloading the UpdraftPlus log file, from the WordPress back-end, will bring the site down in this manner.
    • Thoughts on those? I am happy to post my log file for your review, but only if you can confirm that it contains no sensitive information.

      Thanks.

    Plugin Support bornforphp

    (@bornforphp)

    Hi,

    Sorry for the delay!

    Can you please add the logs to pastebin.com and share the link with us?

    Thanks,
    Harshad

    The file is 3 MB in size, which exceeds Pastebin’s limits. Will this Google Drive link be sufficient:

    https://drive.google.com/file/d/1Q61ueH58ZEWMsFgsLAlcI2PANnxdCzcv/view?usp=sharing

    Plugin Support bornforphp

    (@bornforphp)

    Hi,

    Though the backup seems to be completed, the logs it shows following error occurred:
    15273.078 (2) Binary zip: error (code: 9 – look it up in the Diagnostics section of the zip manual at http://infozip.sourceforge.net/FAQ.html#error-codes for interpretation… and also check that your hosting account quota is not full)

    Can you please check if your disk quota is not full?

    Thanks,
    Harshad

    >> Can you please check if your disk quota is not full?

    The disk space quota is certainly not full (2 GB out of 10 GB used). But, could that same error occur if *other* server resource limits were exceeded? If so, what specific resource limits could trigger that error?

    What about the three server resources below? If my server temporarily exceeded those resources, could it trigger the UpDraftPlus error message you’re referencing?

    * Physical Memory Usage
    * I/O Usage (in MB/s)
    * CPU Usage
    *

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    From the error code, it does appear that the zipping process is sometimes interrupted by the server.

    Has the server exceeded any of those resources during the backup time?

    I can also see that there is an almost 4 hour gap between the first and second run.
    This could indicate that the site scheduler is not working correctly.

    Please could you install the free WP Crontrol plugin, and then go to WP Admin->Tools->Cron Events?
    Is there a warning or error message at the top of that page?

    >> Has the server exceeded any of those resources during the backup time?

    Yes, At least two specific server resources are exceeded during the backup. Before the backup, those resources are at zero. As soon as the backup begins, they rise to max level and remain there for the duration of the backup, then return to zero. Those two server resources are Physical Memory Usage (Max = 256 MB) and I/O Usage (max = 1 MB/s). Also, CPU Usage rises high (~50-75%) during the process, but doesn’t reach 100%.

    >> Please could you install the free WP Crontrol plugin, and then go to WP Admin->Tools->Cron Events?
    Is there a warning or error message at the top of that page?

    There is an error:

    >> There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    cURL error 28: Operation timed out after 3001 milliseconds with 0 bytes received

    Thoughts?

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    It appears that the scheduler is not able to trigger scheduled events correctly.

    Please could you ask your hosts if ‘loopback’ connections are disabled on the server and, if so, could they be allowed?

    You can also try enabling the alternate cron system, by adding the following line of code to your wp-config.php file (just under the database credentials):
    define( 'ALTERNATE_WP_CRON', true );

    This is a backup system for the scheduler, which should allow scheduled events to run.

    Does this allow the backups to run in a more timely manner?
    You may still see the zipping timeout errors, but the plugin should be able to recover much faster.

    Sorry for the delay. I was waiting on my web host support to reply.

    >> Please could you ask your hosts if ‘loopback’ connections are disabled on the server and, if so, could they be allowed?

    I asked them if they could be allowed, and they said they cannot enable HTTP loopback connections on my server due to security precautions. I’m on a shared server.

    In light of that, should I try the alternate cron suggestion?

    Thanks.

    Plugin Contributor DNutbourne

    (@dnutbourne)

    Hi,

    Yes, I would recommend enabling the alternate cron.

    Please be aware that this will cause an extra argument to sometimes be appended to the site URL, e.g.:
    http:example.com/page/?doing_wp_cron=1540291809.9525260925292968750000

    Hello. I have an update to this. I implemented the alternate cron and ran another backup. This backup required about three hours to complete. and again my site went down several times during the process. I had debugging enabled via the UpdraftPlus settings.
    I would like to send you the log file, but when I try to download it via the back-end (“Download most recently modified log file”), it encounters an error (screenshot). Is there another way to obtain the log file, perhaps via FTP?

    Thanks.

    OK here is the new log file, which I downloaded via FTP (from the /updraft/ directory). Let me know if you have issues viewing it.

    Thanks.

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.