WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Events not publishing/Page not found

[Resolved] Events not publishing/Page not found

  • Hi,
    I added The events calendar to a second install of wordpress in a subdirectory to start redesigning my site. I have it also installed on the original wordpress install and it works fine.

    However, on the second install I can publish an event and when I go to view the event, I get page not found. When you view the full month calendar, the events do show up in calendar view but when you try to click on an event from the calendar, you get page not found (You can hover over the event in the calendar and it shows the details) I have a sidebar widget on the home page and the event link (title and duration) show in the widget, but you also get a page not found when you select an event from widget.
    When you look at the url in the page not found for whatever event you’ve selected, it is pointing to the correct url. I can publish an event and copy the permalink into the browser and it shows page not found. I can publish it and click “preview changes” and get page not found

    I exported events from the original calendar and imported them into this install. I thought that may be the problem, however I tried creating new events and get the same problem.
    Here are some of the urls to check what I am getting
    Monthly Calendar
    Sidebar widget
    Any ideas?
    Thanks
    Chris

    http://wordpress.org/plugins/the-events-calendar/

Viewing 15 replies - 1 through 15 (of 26 total)
  • I have exactly the same problem. Have been searching for solutions, but haven’t found it yet…

    Working with WP 3.8 and The Events Calendar 3.3.1.

    Permalinks are set as: /%category%/%postname%/
    When I change permalinks to default, it works! But with permalinks set, the slugs come into play. Then it:
    – does work for /events (calendar or list view)
    – does not work for /event (detail page). I get an error 400 (page not found).

    Hope there is quick solution for this!
    Thanks!

    I changed my permalinks back to default, saved it and then turn them back to post name. The link from the widget now gets to the event post but the formatting of the individual post is all messed up. From calendar view (month view) when I click the event it takes me to the events list view, not the individual event.

    I have this plugin installed on both the working website/directory and development site (wordpress installed in a subdirectory of the working site). Both are running WP 3.8 and Events Calendar 3.3.1 and on the working website it works just fine but the plugin on the development site/subdirectory install is having all the problems.

    Hopefully we get some input from the plugin developer.

    Exact same issue for me. WP 3.8 and version 3.3.1 of the Calendar. Changing permalink structure from Post Name to Numeric fixes it, but I’d prefer to retain the Post Name structure.

    Plugin developer, any advice here?

    cbridges – thanks for the note; I too, was having the same problem (trying to bring up a single event gives a 404). Changing Permalinks from Post Name to Default, then back to Post Name solved the problem for me.

    I spent some time experimenting, here’s what I’ve found:

    1. Permalinks are set to “Post name”
    2. After installation of The Events Calendar, the “Single Event slug URL” is set to “event”
    3. Trying to view a single event (/event/test-event) gives a 404
    4. Set Permalinks to “Default”
    5. Set Permalinks back to “Post name”
    6. Viewing a single event works properly.
    7. I change the Single Event slug URL to “thisEvent”
    8. Trying to view a single event (/thisEvent/test-event) gives a 404
    9. Set Permalinks to “Default”
    10. Set Permalinks back to “Post name”
    11. Viewing a single event works properly again.

    So basically, once I decide what I want the Single Event slug URL to be then I set it, get the 404, do the Permalink two-step, and then the single event displays properly using the slug URL I’ve specified.

    I used Debug Bar to see the difference between a failed and successful query, here’s what I found:

    404 for /event/test-event

    Request:  event/test-event
    Query String:  attachment=test-event
    Matched Rewrite Rule:  [^/]+/([^/]+)/?$
    Matched Rewrite Query:  attachment=test-event

    Successful request for /event/test-event

    Request:  event/test-event
    Query String:  tribe_events=test-event&post_type=tribe_events&name=test-event
    Matched Rewrite Rule:  event/([^/]+)(/[0-9]+)?/?$
    Matched Rewrite Query:  tribe_events=test-event&page=

    Hope this helps – FYI I’m using WP 3.8, Events Calendar 3.3.1

    A bit more information … playing around a bit more shows that if I change the Single event URL slug I don’t actually have to set Permalinks to “Default” and back to “Post name”. Simply navigating to the Permalink Settings admin page and clicking on “Save Changes” is enough to produce the expected behavior and avoid the 404.

    Interesting. I see the exact same behaviour — changing the slug seems to do the trick. Thanks for the pointer!

    Thanks jswartzendruber!

    Unfortunately it doesn’t work for me…
    I am now thinking to check out my .htaccess file, maybe a setting there will solve the problem.

    I don’t know why the plugin creator has failed to respond to this post as it effectively makes their plugin unusable.

    I’m having the same issue. When clicking on the event itself I get 404. I can view the events in list mode but can only see some of the details.

    Same issue here. Im getting a 404 when trying to open a single event page. Some observations:
    When I flush the permalinks, everything looks fine and works as it should until I open an incognito window and try opening an even in it without logging in to wordpress. This breaks the events again, 404s start showing up for both logged in and logged out visitors until I flush the permalinks again and we’re back to square one.
    Any indication that someone is working on this from the dev team would be great because this is kind of a major mess up.

    Same deal here. Lets hope they fix it!

    I’m having the same issue and will try changing the permalinks to default and back again. Agree with thecookiemonster – let’s hope they fix it!

    I’m having the exact same problem and the permalinks switch doesn’t fix it for me. Really wish they would at least acknowledge this is an issue they are working on since it effectively breaks the plugin. Since I haven’t seen anyone else mention it, this problem only occurs for me on individual event posts. If the event is recurring it doesn’t have an issue.

    Plugin Author Barry Hughes

    @websitebakery

    Hi cbridges, sorry for the delay first of all – looks like this one slipped through the cracks. Can I confirm in the first instance that you still need help with this?

    To everyone else, please bear in mind the guidelines detailed in the forum welcome – in particular that even if a problem looks very similar it may not be the same problem, as illustrated by mdv1985’s comment:

    I’m having the exact same problem and the permalinks switch doesn’t fix it for me.

    (That’s not to single you out mdv1985, just to highlight we are quite likely looking at a lot of superficially similar reports with different causes and solutions.)

    For that reason it is best to post new threads of your own.

    Thanks!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] Events not publishing/Page not found’ is closed to new replies.