Support » Plugin: Event Organiser » Events not 'Publishing' or 'Appearing'

  • Resolved HHS_AProctor


    I’m having a very weird issue on our website using the ‘Events Organiser’ plugin when trying at add a new event.

    When adding a new event, everything seems to go through ok, except the event just actually seem to successfully post.

    If you look at an event page for an event, it doesn’t show a date or time for the event, despite specifying it on the add event page.

    Example event:

    When looking at the events list in the dashboard, all new events i’ve tried to create don’t seem to have a start or end date specified (despite these fields being populated when submitting the event).

    Hopefully this has made sense!

    I can’t see anything glaringly obvious (not even in debug mode), and the theme or other plugins don’t seem to be causing a conflict – although this is not something easily testable due to the nature, and the size of the website.

    I’ve even upgraded to the 1.7 beta to see if that would clear the problem, alas it remains.

    Please help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Seems I am having the same issue. Haven’t completely tracked the issue down, but it appears as though the post table is getting populated, but the eo_events table is not getting the event added.

    Doing a bit more tracking down later today, anyone else have any thoughts?


    I’ve been able to trace my issue to the line that inserts into the eo_events table in _eventorganiser_insert_occurrences.

    What’s odd, is that this works fine on my Mac, but not on our production Windows system. This is even after I copy the entire wordpress install (file and mysql) to my local system and run the same commands. The table name and occurrence_input array both look fine.

    The insert command returns false. There are no wpdb errors, and the wpdb insert_id is of the last insert to wp_postmeta, not of this insert (which is not in the database).

    *Sighs* Any thoughts?

    Sorry you to seem to be experiencing problems.

    First thing to try is disabling all other plug-ins and switching to TwentyEleven/Tweleve (if you’ve got an offline / test site then you’ll probably want to do it there rather than live).

    Secondly, regarding esimmons_mjp – is the event table being populated with dates? If you can’t check it directly (e.g. via phpmyadmin) – does the admin table display the events correctly?

    @esimmons_mjp – looks like you’ve done a pretty good job of narrowing it down. Does setting WP_DEBUG to true reveal any errors (though sounds like you’ve probably already tried that). One thing to check is what columns exist in the table. Columns have been (should have been) removed as they’ve deprecated – but if they haven’t for some reason, and they’re not receiving value from the insert command (but they are expecting input) then that could cause this issue. Though I’d expect an error message…

    (I assume you’ve tried printing any error messages from $wpdb?).


    As i’ve previously mentioned, due to the size and nature we run our website, i’d rather not change the theme to the default if possible, as I don’t want to be going through each and every page to ensure the correct page template is in use when we switch back to the theme we use.

    Especially when it used to work with our theme, and nothing has changed with the theme since it’s stopped working.

    I have however tried disabling plugins, which hasn’t made a difference.

    I’ve just noticed in our database that it’s added the event into the wp-posts table in the database, however there is no entry in the wp-eo-events table relevant to the event i’ve recently posted.

    I have enabled WP_Debug mode, however this hasn’t produced any glaringly obvious errors.

    Hey Stephen,

    Finally got things worked out. The issue was I still had the event_allday column. Still don’t know why it failed on Windows but worked on Mac with an exact copy of the code and database. (The column was there in both instances. The MySQL versions are different, but the DB options are exactly the same.)

    Once that column was deleted, things started working beautifully. (And once I figured out that IIS was redirecting some of my php errors….).

    I might recommend adding something that will catch errors around the $wpdb->insert($wpdb->eo_events, $occurrence_input) line, since it’s silently ignoring them now.

    Thanks for a great plugin!

    Plugin Author Stephen Harris


    @esimmons_mjp – brilliant! I’ll look into some error catching (when debug is turned on) – also, I shall ensure the column is removed with the next update. That should prevent any repeat incidents. Seems it only effects Windows servers.

    @hhs_aproctor – have you looked at the database – could it be the same problem as @esimmons_mjp?

    Apologies for the late response. My issue seemed to be exactly the same as @esimmons_mjp

    I’ve manually deleted the event_allday column from wp-eo-events table and everything sprang into life.

    So thanks very much for your support on this, we have our events system back 🙂

    Plugin Author Stephen Harris


    Brilliant, I’ll try to make sure this doesn’t happen for others :).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Events not 'Publishing' or 'Appearing'’ is closed to new replies.