Support » Plugin: All-in-One Event Calendar » Events no long expand in Agenda view

  • Resolved WP Monkey

    (@scdesmond)


    Our events list displays the Agenda view by default, and now clicking on the plus does not expand the event details.

    This started recently, and may have coincided with updating to v4.5.2.1. Looking at the console, I’m seeing these errors:

    Uncaught SyntaxError: Unexpected token *
    c1ac4.js:40

    Which is the calendar.js

    Here is the page http://ow.ly/kz3j30cgC9O and I’m noticing that the calendar works as it is supposed to when I am logged in, but not in multiple browsers when I am not.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same situation for me,
    thank you for your help:

    http://www.otletgumi.hu/fna/calendar/

    @amoditer Were you able to fix it?

    Really needing an answer to this ASAP!

    @scdesmond closing this as there is now an open ticket we are working on.

    All others:

    This could be a result of a plugin or theme conflict.. Please try a different theme temporarily such as Twenty Seventeen, or, disable all plugins and then check if the problem recurrs — then re-enable each one until you find which one caused the problem.

    – Make sure that your Calendar page is set to the right page in the settings (no need to use shortcode on a page set as the default in the plugin settings)

    – Try turning on/off “Strict compatibility content filtering” in Events -> Settings –> Viewing Events.

    – Try turning on/off “Use frontend rendering” in Events -> Settings –> Advanced

    – Try resetting permalink settings to Plain and then back to your custom style

    I found that I could fix this by turning off JS minification, which I would like to keep. But thank you for the other suggestions – would any of them specifically address this issue and minification of JS files?

    Yes the first step would address that if you are using a plugin to do the minification of javascript files. Otherwise thanks for the additional tip.

    I just have the same problem… my events dont expand in agenda views, it doesn’t find the event whereas it exist…

    http://www.b2btwins.com/fr/event/smart-energies-expo-2017-rendez-vous-b2b-professionnels-de-lenergie/?instance_id=104

    what can i do ?

    @b2btwins

    Your event URLs are not correct most likely due to the use of translation plugin. I suggest going to your WordPress dashboard > Settings > Permalinks > change to a different setting and Save Settings, then check your event URL again.

    The tip within the post from WP monkey is the only solution so far. But as him, I would like to keep the minification of js. Can this be prevented somehow?

    Hi @akeem040767,

    Only thing I can suggest is make sure your WordPress installation is up to date, and that your host is using PHP 5.6 or later as earlier versions are depricated and unsupported, and lastly, update to the latest version of the calendar plugin.. failing that, disable any potential theme or plugin, and lastly if the problem still occurs, turn off javascript minification.

    Hey Sunny.
    I had to turn off js magnification. I prefer it over disabling my theme or any needed plugins 😉
    Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Events no long expand in Agenda view’ is closed to new replies.