Support » Plugins » Events Manager Plugin – Google map stuck on "Loading Map"

  • This is my first time using this plugin and so far I love it. My only issue is that the Google Map for the event will not display. It is stuck on a grey box with the message “Loading Map”. I have tested multiple events and browsers, same result. I have also deactivated all my plugins except for Events Manager, same result.

    Anyone have any idea on how to fix this?


Viewing 14 replies - 1 through 14 (of 14 total)
  • can you try it on a default theme and do you have a sample link?

    hmmm…it does work on the default theme.

    Here is the link with the custom theme loaded. I appreciate you taking a look. The site is in development, I wonder if something was programmed wrong which is causing the error.

    Demo link

    found these errors on your site:

    Timestamp: 4/5/2012 9:15:07 PM
    Error: $(".em-calendar-wrapper a").undelegate is not a function
    Source File:
    Line: 42


    Timestamp: 4/5/2012 9:15:06 PM
    Error: a.delegate is not a function
    Source File:
    Line: 836

    probably your theme causing these errors; please see how your theme loads javascript particularly jquery.

    I have been having trouble with trying to get jquery to load correctly. I finally followed the code from Chris Coyier to enqueue it in the header so that it loads the version included with WordPress.

    The code in my header is:

    <?php wp_enqueue_script('jquery'); ?>
    <?php wp_head(); ?>

    That is the only place I am calling it. Is that correct or causing the issue? I appreciate your help in figuring this out.

    can you try to remove or comment this line <?php wp_enqueue_script('jquery'); ?> ?

    I just removed it from header.php

    Wouldn’t that be if I was writing any jQuery for the site? I am just trying to get it to load so that (in this case) the map displays. Sorry if I misunderstood.

    try to compare the header of default theme and your theme. here’s my test site header

    <script type='text/javascript' src=''></script>

    yours is

    <script type='text/javascript' src=''></script>

    looks like your site is loading a different jquery.

    I am not seeing anywhere in the default theme header or functions that calls jquery. I have removed each of the lines in my header that relate to scripts and it is still giving me the “loading map”.

    I will have to look at this in the morning with a clear view. I appreciate you trying to help.

    also check your other plugins.

    I deactivated all other plugins and still got the error when I tried earlier today. I am sure it is something simple I am just overlooking…hopefully 🙂

    btw, what’s your theme name?

    It is a custom theme I am developing for this project. Right now it is just named ahansendesign

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Events Manager Plugin – Google map stuck on "Loading Map"’ is closed to new replies.