Support » Plugin: Events Manager » Events Manager Doesn’t format properly and site spins when user registers

  • Any of the events there have the same problem.

    1. Spins for a long time
    2. Sends email without the event detail

    Please advise

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Support timrv

    (@timrv)

    Hello,

    Can you perhaps check the following?

    1. Make sure you’re using the latest EM and EM Pro Version
    2. Make sure your using PHP 7.1
    3. Please try and Install WP Safe Mode (https://wordpress.org/plugins/wp-safe-mode/)
    – Activate and Enable Safe Mode. Please make sure that on the settings a twenty series theme is selected.
    – When activated it would help you test as if the Webiste only plugin activated is EM and twentyseries theme

    Hi @timrv

    We’re on an Nginx and PHP 7.2 server. And #1 issue @paulelisiegel mentioned is due to an ajax error. It triggers timeout which is set to 300 seconds.

    Could this be due to PHP 7.2?

    Thanks!

    • This reply was modified 5 months, 3 weeks ago by  Tharindu.
    • This reply was modified 5 months, 3 weeks ago by  Tharindu.

    Here’s a screenshot of ajax request https://gyazo.com/0c08411924ec8c41ed133c0cfbd5dae9

    Nginx is recording a Upstream timeout on it’s error log. I’ve tested this on PHP 7.0, PHP 7.1 and PHP 7.2 now. Still the same result.

    I’ve tested with WP Safe Mode and nineteen theme. Still the same. This was on PHP 7.1.

    @timrv Can you help is solve this problem??

    We are happy to upgrade to Pro bit not if that doesn’t solve the problem or you can’t help us solve it.

    Please advise ASAP.

    Plugin Support timrv

    (@timrv)

    Hello,

    I think the Ajax issue is due to your SSL/HTTPS not configured properly. When I check the logs is displays. This is a Site issue and not from EM Side. You could try Installing https://wordpress.org/plugins/really-simple-ssl/ if it can fix the insecure loading for files and insecure request.

    Mixed Content: The page at 'https://starweaver.com/event/tools-and-techniques-of-machine-learning-and-data-science/' was loaded over HTTPS, but requested an insecure stylesheet 'http://cdnjs.cloudflare.com/ajax/libs/animate.css/'. This request has been blocked; the content must be served over HTTPS.
    autoptimize_124f12346da9b6d7a08c093352ef9511.js:6 JQMIGRATE: Migrate is installed, version 1.4.1
    (index):159 fired
    7[Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive. See <URL>
    (index):1 Mixed Content: The page at 'https://starweaver.com/event/tools-and-techniques-of-machine-learning-and-data-science/' was loaded over HTTPS, but requested an insecure stylesheet 'http://cdnjs.cloudflare.com/ajax/libs/animate.css/'. This request has been blocked; the content must be served over HTTPS.

    Thanks @timrv

    We used the WP Safe Mode method you mentioned above. That setup did not have any mixed content warnings. But we still got endless spinning icon then the getaway timeout.

    So we can’t conclude it’s due to that mixed content error. Is there anyway we can disable ajax on submissions?

    Thanks!

    @timrv Can you give us an update on this. It is VERY problematic for us as we can’t use your system for registering if we can’t fix this.

    Plugin Support timrv

    (@timrv)

    Hello,

    Here is a screenshot that shows the Mixed content issue on your site. https://monosnap.com/file/KUgbGU4QAhOIBqLmAOcJC4B1CQvvGJ

    As I tried to explain, we no longer have this mixed content issue when we disable all other plugins and use a default WordPress them. And we still can’t get Events to work.

    You can also try our staging website where we don’t have mixed content issue but still can’t get Event registration forums to work.
    https://staging.starweaver.com/event/what-ml-can-do-for-you/

    Thanks!

    Plugin Support timrv

    (@timrv)

    Hello,

    Visiting the link again and I could seem to book already. Here is a screenshot. https://monosnap.com/file/eAZTpOljNxGT16mBuku4Ovalmhlk7R

    Sorry that I became confused with the thread. All this time I thought there is 2 different sites that’s having the issue because you’re using 2 Different Accounts to reply.

    • This reply was modified 5 months, 2 weeks ago by  timrv.

    Yes, @timrv

    We also observed that. Sometimes people are able to book on their first attempt. And then it stops working. You can try any other event now, or the same event again. It won’t work.

    May be something to do with cookies?

    We’re interested in upgrading to pro version, but we need to make sure that we’re able to solve this. Would it help if we upgrade now?

    P.S. Paul, the other person replied is my boss. He owns the website. I’m his sysadmin.

    • This reply was modified 5 months, 2 weeks ago by  Tharindu. Reason: spelling
    Plugin Support angelo_nwl

    (@angelo_nwl)

    freddy63, you can instead create a separate thread to avoid confusion with the original author of this thread.

    @angelo_nwl We both talk about same issue on same server on same website. I’m not sure why that’s necessary.

    • This reply was modified 5 months, 1 week ago by  Tharindu. Reason: spelling

    BTW, I’m not sure why this issue has been marked as resolved. It’s not resolved. @paulelisiegel can confirm that.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.