The Events Calendar
Events List Widget View All Link Repeatedly Results in 404 Page (4 posts)

  1. askwpgirl
    Posted 2 years ago #

    I am using The Events Calendar on http://bcap.org. The Events List Widget is used in the sidebar on the home page as well as other pages.

    The View All Events link in the widget goes to:


    This link often displays a 404 error and sometimes does not. It is random and in the same day can show the upcoming events once, then 404, then shows, then 404, then shows.

    I turned on error reporting in the wp-config file and saw this error on the site:

    Notice: Undefined property: WP_Query::$tribe_is_event_query in /home2/mysite/public_html/wp-content/plugins/the-events-calendar/lib/the-events-calendar.class.php on line 2127

    I don't know if that is related to the 404 error being generated randomly or not.

    I tried doing a clean install of The Events Calendar plugin on another site, and the View All Events link goes to:

    /events/month/ rather than /events/upcoming/

    I did a clean install of The Events Calendar plugin on the bcap.org site, but this did not change the problem.

    The problems started occurring after the major update to The Events Calendar.


  2. moonvader
    Posted 2 years ago #

    link is broken
    you can edit
    line 124
    echo '<p class="tribe-events-widget-link"><a href="' . $event_url . '" rel="bookmark"></a>
    change href

  3. askwpgirl
    Posted 2 years ago #

    Hi there, Moonvader, yes, I considered editing that line. I'll have to make sure my edit isn't overwritten with the plugin updates.

    IMHO, the widget should go to a valid URL in the first place and be consistent between new installs and updates. At any rate, I went ahead and modified that line since my client can't continue to have 404 errors randomly. Would love to know why this was generated an error in the first place (albeit randomly).

  4. Barry Hughes
    Plugin Author

    Posted 2 years ago #

    Hi askwpgirl:

    Can you confirm which version of the plugin you are currently using? Can you also confirm if this occurs with all other plugins disabled and only a default, unmodified theme such as Twenty Twelve running?

    I realize you said you tested on a clean site - I'm not sure though if you could exactly replicate this or not (if it linked to month view, you probably had month view set up as the default view in Events → Settings → Display).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • The Events Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic