WordPress.org

Support

Support » Plugins and Hacks » The Events Calendar » Events disappearing from list before they even starts

Events disappearing from list before they even starts

  • Hi, I have a list setup on the home page of my website. All of my events show fine, until the date of the event, when events disappear before the events start. I’ve tried setting them up as all day events, but the problem persists.

    Can anyone give me hand?

    Thanks!

    Sony

Viewing 9 replies - 1 through 9 (of 9 total)
  • Having the same problem. “previous events” tab goes to a file 404 with the url “http://www.*.com/category/events/past”, but today’s events are lost in limbo.

    I had to change my server time to UTC. I live in Texas and had the server time set to Chicago for normal timezone settings, I also tried UTC-5 but no help. Did the UTC-4 and event came up. I say there is a time compatiblitiy issue in programming.

    I am having the same issue – I live in Denver and if I put in UTC-6 (which is the right zone) my event disappears, however if I put in UTC+6 (which is 12 hours ahead, my event appears – does anyone know how to resolve this?

    I could fix the problem for me.

    The problem is a wrong date-string.
    You could download a fix here at my blog.

    This post is in German language. Link is called:
    Download fixed the-events-calendar.class.php

    Thanks you SO much!!

    raasdesign

    @raasdesign

    I have the latest version of TEC (2.0.1) and WP (3.2.1) and I’m having this same issue.
    @fenegblog your fix isn’t for this version is it? I looked at the line that you fixed and it’s completely different in the new version. Any ideas on fixing it in 2.0.1?

    feneblog

    @feneblog

    @raasdesign: Yes, the fix is for the old version of the plugin. Maybe the fix is similar to the old version.

    You could try to edit lib/tribe-date-utils.class.php and change the constants of the date-format.

    I couldn’t try it, because I still use the old version.

    bwp

    @bwordpress

    If I understand the translation, it’s really just ONE line we’d need to tweak, is that correct, feneblog?

    Solution of the problem

    The attribute “$ this-> date” is assigned to an incorrect date format.

    the-events-calendar.class.php (Goals: 1237)
    1

    $ this-> date = date_i18n (The_Events_Calendar: DBDATETIMEFORMAT);

    I adapted this line and the required date format entered, since the constant is overwritten during the term anyway.
    1

    $ this-> date date_i18n = (‘Y m d H: i: s’);

    After this change will also appear with me today dates back properly.

    Who does not itself change the line like, you can download the custom file:
    Download the fixed-events calendar.class.php

    The fixed file in the plugin directory, simply replace wp-content/plugins/the-events-calendar /.
    I’m glad if you give me just leave a comment if you were able to fix that problem.
    Selection of the time does not work with new events

    Event Date Picker
    If you take the check “all day” appears out, but not the choice of the time.

    A solution to the problem can be found here:
    http://rvo.me/dia/2011/the-events-calendar-event-options-jquery-fix/

    I hope now that the new Events Calendar Pro 2.0 will be released soon.

    Also, regarding the rvo.me/dia patch, I noticed it’s significantly different from the original code (omits text and other changes) — is it completely functional and compatible? (I, too, am still using TEC 1.6.)

    Anyhow, thanks…

    feneblog

    @feneblog

    If I understand the translation, it’s really just ONE line we’d need to tweak, is that correct, feneblog?

    Yes, this simple tweak did it for me.

    The jquery-solution fixed my other problem without any negativ impact.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Events disappearing from list before they even starts’ is closed to new replies.
Skip to toolbar