Support » Plugin: The Events Calendar » Events Calendar&LearnPress incompatibility

  • Resolved juliarrr

    (@juliarrr)


    After updating the Events Calendar plugin to 4.6.18 and LearnPress plugin by ThimPress to 3.0.9 (the latest version) there appears the incompatibility issue – it is impossible to add, delete or edit widgets. The error itself is supposedly in the Event Calendar file, BUT, if you disable LearnPress, everything works fine. On the contrary also. Here is a screenshot of the error: https://www.screencast.com/t/rqNQtorchc

    On the default theme (TwentySeventeen) it also occurs.

    Please let me know if the fix will be included into the next Events Calendar plugin update. Looking for your reply, thank you in advance.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ed

    (@erishel)

    Hi @juliarrr,

    Thanks for your interest in our products.

    After taking a look at that error, it looks like LearnPress and The Events Calendar are trying to load different versions of Select2 which is a jQuery replacement for select boxes.

    We are using an older version of Select2 which may be contributing to the conflict here. I’m sure that there are pros and cons for us to load the current or just newer version of Select2, but this is what we are using at this time.

    You can try something like:

    if ( is_admin()  ) {
            wp_deregister_script( 'tribe-select2' );
        }  

    To deregister or dequeue the script, but keep in mind that this may cause issues since the script was developed for this version and certain functions may now be deprecated. I think I read somewhere that one of the theme developers that create The Events Calendar friendly themes do this.

    Hope that helps!

    Plugin Support Ed

    (@erishel)

    Hey there,

    Since this thread has been inactive for a while, I’m going to go ahead and mark it as resolved. Don’t hesitate to create a new thread any time you help again!

    Ed 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Events Calendar&LearnPress incompatibility’ is closed to new replies.