• Hi,
    I am on version 6.1.1 in my dev site. I want to maintain my own format, so I set Enable All Styling to No. But the Events Calendar widget on my sidebar is not working. The “<” and “>” are quite big and display all the calendar numbers. It no longer display a grid calendar on the sidebar. How can this be resolved? Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I too am having this same problem. In addition to the description above, the days of the week and the number of days are listed in one column all the way down the page.

    Any idea on how to resolve this?

    Thread Starter francoc30

    (@francoc30)

    “the days of the week and the number of days are listed in one column all the way down the page.”
    That is what I have.

    Some more people with the same problem. I hope someone can help and resolve this problem.

    Same problem

    • This reply was modified 1 year, 8 months ago by julienamta.
    TreeTrail

    (@aprilschmitt27)

    If you wish to revert to the original concise mini calendar widget, paid support recommended doing this:

    PATH:

    your website

    public_html

    wp-content

    themes

    theme-child

    create new:

    “plugins” folder

    “events-manager”
    “templates”
    ->add copy in version 5 file:
    “calendar-small.php”

    Hi TreeTrail,

    I would be happy to give that a try, but where can I find calendar-small.php?

    TreeTrail

    (@aprilschmitt27)

    Hi cer0c,

    I’d attach it here if I knew how. Find a version 5 install, look in this path:

    your website
    public_html
    wp-content
    plugins
    events-manager
    templates
    templates (yes a 2nd folder down, but don’t make 2 in your child theme)
    calendar-small.php

    ~April

    Hi April,

    Can you matbe copy the code into your reply?

    Thanks in advance,

    Bart

    I pulled an old version of events-manager and this is the small-calendar.php file:

    <?php
    // as of version 6, this is not to be used further, see file below
    include(EM_DIR.'/templates/calendar/calendar.php');

    I hope the bboard code tags don’t mess it up.

    However, I added the code to the version 6 events-manager, and it did not fix the calendar.

    Hi all,

    I’ve found version 5 of calendar-small.php, see code block below. Which gives me back the “old” small calendar, when placed in

    ../wp-content/themes/my-child-theme/plugins/events-manager/templates

    <?php 
    /*
     * This file contains the HTML generated for small calendars. You can copy this file to yourthemefolder/plugins/events-manager/templates and modify it in an upgrade-safe manner.
     * Note that leaving the class names for the previous/next links will keep the AJAX navigation working.
     * There are two variables made available to you:
     */
    /* @var array $calendar - contains an array of information regarding the calendar and is used to generate the content */
    /* @var array $args - the arguments passed to EM_Calendar::output() */
    
    $EM_DateTime = new EM_DateTime($calendar['month_start'], 'UTC');
    ?>
    <table class="em-calendar">
    	<thead>
    		<tr>
    			<td>" rel="nofollow">&lt;&lt;</td>
    			<td class="month_name" colspan="5"><?php echo esc_html($EM_DateTime->i18n(get_option('dbem_small_calendar_month_format'))); ?></td>
    			<td>" rel="nofollow">&gt;&gt;</td>
    		</tr>
    	</thead>
    	<tbody>
    		<tr class="days-names">
    			<td><?php echo implode('</td><td>',$calendar['row_headers']); ?></td>
    		</tr>
    		<tr>
    			<?php
    			$cal_count = count($calendar['cells']);
    			$col_count = $count = 1; //this counts collumns in the $calendar_array['cells'] array
    			$col_max = count($calendar['row_headers']); //each time this collumn number is reached, we create a new collumn, the number of cells should divide evenly by the number of row_headers
    			foreach($calendar['cells'] as $date => $cell_data ){
    				$class = ( !empty($cell_data['events']) && count($cell_data['events']) > 0 ) ? 'eventful':'eventless';
    				if(!empty($cell_data['type'])){
    					$class .= "-".$cell_data['type']; 
    				}
    				?>
    				<td class="<?php echo esc_attr($class); ?>">
    					<?php if( !empty($cell_data['events']) && count($cell_data['events']) > 0 ): ?>
    					" title="<?php echo esc_attr($cell_data['link_title']); ?>"><?php echo esc_html(date('j',$cell_data['date'])); ?>
    					<?php else:?>
    					<?php echo esc_html(date('j',$cell_data['date'])); ?>
    					<?php endif; ?>
    				</td>
    				<?php
    				//create a new row once we reach the end of a table collumn
    				$col_count= ($col_count == $col_max ) ? 1 : $col_count+1;
    				echo ($col_count == 1 && $count < $cal_count) ? '</tr><tr>':'';
    				$count ++; 
    			}
    			?>
    		</tr>
    	</tbody>
    </table>
    • This reply was modified 1 year, 5 months ago by cer0c.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Events Calendar widget not working when Enable All Styling set to No’ is closed to new replies.