• Resolved pbohaccz

    (@pbohaccz)


    Since some update, all events that covered multiple days show only the first day of the event. Is this part of demo or is it a bug?

    In such a case, we can’t use the plug-in like it is anymore, as we use it for bookings, which are almost always over more days.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • We are having the same issue. Looking forward to a response.

    Plugin Support Erica

    (@eeide)

    Hi @pbohaccz and @josev3,

    Thanks for reaching out!

    Are you both running the latest version of The Events Calendar (as of today, that’s 6.0.1.1)?

    I’m not able to replicate this on my end (screenshot), so at this point, it doesn’t appear to be a bug. Perhaps there is a conflict happening.

    Please rule out any conflicts by following our guide, Testing Conflicts With Themes and Other Plugins.

    Let us know how that goes!

    Thank you,
    Erica

    Thread Starter pbohaccz

    (@pbohaccz)

    Hello Erica,

    thank you for your reply. I have followed all steps mentioned in the link. But. It did not bring us much.

    I am not sure, what is ment by THEME override exactly, however, I did not find the folder mentioned there at all, so I suppose we do not use it.

    Would you have any other tip, what we could do?

    Our Theme is BASKERVILLE, WP version is the latest 6.1.

    Regards, Petr

    Plugin Support Abz

    (@abzlevelup)

    Hi @pbohaccz, I suspect it has something to do with the permalinks Single event URL slug using /events as it is reserved for the archive page. Could you try changing it to /event or something unique? Please clear any caching for both third-party plugins and server-side (if you have any). It would also be good to flush permalinks.

    Let me know if that makes a difference.

    Best,
    Abz

    Thread Starter pbohaccz

    (@pbohaccz)

    Hallo ABZ,

    thank you for an advice. It did not help. I have changed the configuration to kalendar and udalost (czech words for events, event) and flushed permalinks by changing the permalink settings several times.

    There is no difference in the end.
    Would you have any idea?

    Petr

    Plugin Support Abz

    (@abzlevelup)

    Hi @pbohaccz, apologies for the delay in my reply here. I’m back now. Sorry to hear that it didn’t work. Could you try updating to the latest version of the plugin? Then clear any caching and flush permalinks.

    To be safe, we’d recommend conducting tests and updates on a Staging Server. Also, please keep a working backup of your website.

    Let me know how it goes.

    Best,
    Abz

    hi Abz,

    thx, I tried flushing the permalinks and clearing cache, but it’s still the same. When I tried to test the conflicts with the theme, apparently there was a conflict (we use Baskerville theme). Please, do you have any idea how to fix this?

    Best rgrds

    Josef

    Plugin Support Abz

    (@abzlevelup)

    Hi @josefovo, sorry to hear about this. Could you share the direct URL to the page you’re having issues with? I’d like to check and help you with this one.

    Please do not share any credentials, this is for us to follow the WordPress Forum Guidelines.

    Best,
    Abz

    It’s the same as @pbohaccz already sent before, we are from the same NGO.

    link: https://www.domaslav.cz/kalendar/

    Thx for helping! 👍

    Plugin Support Abz

    (@abzlevelup)

    Hi @josefovo, yikes! Apologies, I missed that. I could see that the plugin is already updated to v6.0.4. Interesting.

    Could you try switching the theme, then adding a multi-day event? Also, were you able to do the test for conflicts? I am not entirely sure it is from the theme since the front end is fully functional.

    Also, were you able to migrate to v6 without hiccups?

    Looking forward to hearing from you.

    Best,
    Abz

    Hi Abz,

    I tried your link to test conflicts and by switching the theme to Twenty Twenty, multiday events look better (https://www.domaslav.cz/wp-content/uploads/2022/11/Screenshot_calendar.png). sure, totally different desing, but there are dots for every day included in the event.
    I also tried to create the multi day event in the new theme (“multiday test”, 29. – 30. 11. (11 == listopad)) as you can see on https://www.domaslav.cz/kalendar/ but by switching back to Baskerville, everything seems as before.

    Thx for helping!

    Best rgrds

    Josef

    Plugin Support Abz

    (@abzlevelup)

    Hi @josefovo, it seems like a conflict with Baskerville Theme — I was able to replicate it, although it shows all the multi-events on the mobile view, not on the desktop.

    See the screen recording here:
    https://share.getcloudapp.com/nOu1weyy

    I’m curious, could you interchange the settings under Display → Default stylesheet used for events templates and Events template? Head over to Events → Settings → Display and try different settings for the page template.

    See if that makes a difference and ensure that any template is not causing the issue.

    Best,
    Abz

    Hi Abz,

    I tried to switch this settings from Tribe Events Styles to Skeleton Styles and it behaves the same – works on mobile version, doesn’t work on desktop.

    Best rgrds

    Josef

    Plugin Support Abz

    (@abzlevelup)

    Hi @josefovo, I figured out that your theme is overriding one of our selectors for events. Finally 🧐.

    I’d recommend doing a Custom CSS. Go to Appearances → Customize → Additional CSS and insert this Custom CSS here:

    article.hentry.tribe_events {
        overflow: unset !important;
    }

    See the screen recording here:
    https://share.getcloudapp.com/mXubEpEo

    See if that works on your end. Let me know how it goes.

    Best,
    Abz

    Thread Starter pbohaccz

    (@pbohaccz)

    @abzlevelup , @josefovo

    It works! Thank you!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[EventCalendar] Event shows only a first day’ is closed to new replies.