Support » Plugin: The Events Calendar » Event slug missing /

  • Resolved mills.joe

    (@millsjoe)


    URLs built by the plugin now do not add a / after index.php – so rather than my default event slug being index.php/calendar, it is now index.phpcalendar, which obviously doesn’t exist.

    The plugin is building the pages in the correct places, but is linking to the wrong ones, if that makes sense?

    https://wordpress.org/plugins/the-events-calendar/

Viewing 15 replies - 1 through 15 (of 15 total)
  • I am experiencing the same problem.

    Hi there,

    I am also experiencing the same issue.. Any idea how to resolve this?

    Thanks.

    I am having the same problem. The slash is being omitted, so none of my links are working! About to launch a major website this evening and we need this working!!

    FOUND THE PROBLEM.

    The documentation states that the permalink option should be set to POST name. I had recently changed mine to Custom Structure, which is what broke the URL. I set it back and it’s all working now.

    IntegriTivity – Thanks so much for figuring this out! I adjusted the permalink setting as you recommended and all is now working fine.

    My permalinks are set to Post Name and still getting this error. In addition, getting an insufficient permissions error when I try to access the TEC settings.

    Previous version(s) were fine – I’m going to roll back.

    Rolled back to 3.11.2 and error is gone.

    IntegriTivity – Thanks for figuring out how to solve this problem! Dave 🙂

    Brook

    (@brook-tribe)

    Howdy Guys,

    I appreciate the bug report. It sounds like your servers are using pathinfo permalinks. To be honest we have not traditionally tested for those. In addition to filing the bug report just now, I am going to discuss with the team whether we can get an automated test in place for this.

    Thanks for sharing the solution dave. Changing to postname or default permalinks should work for now. Or rolling back as joshuaiz. We will get this fixed as soon as we can. We are just about to release a maintenance update, but it is too far along to include a fix for this. Hopefully the release after that will have a fix.

    Thanks again! – Brook

    Thanks for the update. As in my case changing permalinks did not work so hopefully the upcoming release will solve it.

    Plugin Author Brian

    (@brianjessee)

    Hi,

    This should be fixed in 3.12.2, which if everything goes to plan should be out in a couple days at the latest.

    Thanks

    Plugin Contributor geoffgraham

    (@geoffgraham)

    Hey folks,

    Just want to let you know that 3.12.2 just shipped and a patch for this issue was included. Please update and feel free to drop us a new note if you continue to bump into any issues with this. We appreciate your patience while we worked on this–thanks for your support!

    Cheers,
    Geoff

    Hi there. I am having this same issue. Please help!

    Events URL Slug is generating as http://www.staging.bristowmontessori.comevents/

    But the actual page IS working when you click on menu “Calendar” http://www.staging.bristowmontessori.com/events

    As you will see, when you are on the “events” Calendar page, the “View as Month/List/Day” link takes me to http://www.staging.bristowmontessori.comevents/ which obviously does not work.

    Or, when I am using the Events widget area in the “home” page http://www.staging.bristowmontessori.com
    it takes me to
    http://www.staging.bristowmontessori.comevents/
    which doesn’t work

    The settings in the Events Calendar:

    Events URL slug
    events

    The slug used for building the events URL.Your current events URL is: http://www.staging.bristowmontessori.comevents/

    Single event URL slug
    event
    The above should ideally be plural, and this singular.

    Your single event URL is: http://www.staging.bristowmontessori.com/event/single-post-name/

    EVENT CALENDAR VERSION:
    The Events Calendar
    Version 4.4.2 | By Modern Tribe, Inc. | View details | Support | View All Add-Ons

    Using THEME:
    School TimeVersion: 1.1.0
    By aislin

    @bristowmontessori How did you fix this, I am having the same issue?

    Thanks

    @badgerstateweb Yes! I contacted the theme developer for my School Time Theme, and they had an updated theme version. So I installed and it fixed the problem. Good luck!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Event slug missing /’ is closed to new replies.