Support » Plugin: Events Made Easy » Event Plugin Error when using SuperCache in Dashboard

Viewing 9 replies - 1 through 9 (of 9 total)
  • I too am getting this error on the popup box in the plugin page when viewing a plugin’s changelog details.

    Plugin Author Franky

    (@liedekef)

    Ok, I found the reason for this. The solution is simple (and it’s not an error, so you can ignore this for now), but will need to wait until this evening 🙂

    I’m getting the same line when trying to upload an image.

    Since Update of SME my media upload is blocked

    Warning: Invalid argument supplied for foreach() in /www/htdocs/**********/wp-content/plugins/events-made-easy/eme_settings.php on line 186>

    Plugin Author Franky

    (@liedekef)

    That should not happen. It might be that some json call fails of course because php inserts this warning …
    The correct way for production servers is to disable online display of php errors (it is a first vector for attacks: they already know the path on your system if they get such errors).
    So first of all: change your php.ini for that.

    Second, a quick fix:
    add in eme_settings.php, at the beginning of the function eme_options_register (line 144), this:

    $options = array ();

    That should help already.

    That does help

    Plugin Author Franky

    (@liedekef)

    I’m getting similar issues since updating the plugin the last time.

    Will you be publishing an update to the plugin to fix this issue?

    Plugin Author Franky

    (@liedekef)

    Did you try the fix I mentioned above?
    Or else, if you want to try the current devel version: http://downloads.wordpress.org/plugin/events-made-easy.zip

    I was going to release it yesterday evening but it was just too late, so it will happen this evening.

    Thanks, Franky! Everything’s working great.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Event Plugin Error when using SuperCache in Dashboard’ is closed to new replies.