Support » Plugin: Event Organiser » Event Organiser is compatible with WordPress 5.5

  • Plugin Author Stephen Harris

    (@stephenharris)


    There’s been numerous bug reports regarding Event Organiser (and the Pro extension) after updating to WordPress 5.5. The plug-in has been tested against WordPress 5.5 and so should work; all bug reports I have seen thus far have been traced back to other plug-ins which broke with the update.

    In WordPress 5.5, WordPress updated the jQuery version it used which removed some deprecated functions (most notably $.live and $.browser). Any plug-in using these functions will cause an error on the page and will likely break the functionality on that page (e.g. the calendar, or the booking form).

    If you think there is an issue with Event Organiser & WordPress 5.5, please check your browser console. Any javascript errors will appear there, along with the location of the error which can help identify the offending plug-in.

Viewing 1 replies (of 1 total)
  • Thank you for this tip! I’m not a programmer, but stumbled upon the offending plugin by accidentally hovering over the error text after you mentioned pulling up the browser console. You’ve saved me hours and hours of work, because the offending plugin broke EO’s recurrence function. Back to work now, thanks again. A.Hoff

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.