• Resolved conorbryce

    (@conorbryce)


    Hi there,

    I don’t seem to be able to get the GA tracking to work on a button I’ve added to a test page.

    I’ve used the following General Settings (I’ve tried unchecking/checking all the different properties to see if it made a difference – no change):

    Google Analytics Identifier – XX-00000000-0
    Don’t add the GA tracking code – Ticked
    I’m using the Google Tag Manager – Not ticked
    I’m using the Global Site Tags code – Not ticked
    Universal Tracking Code – Ticked
    IP Anonymization – Not ticked
    Advanced Mode – Not ticked

    I’ve set up click tracking with the following parameters:
    Element Name -gaConnect
    Type – Class
    Event Category – Button
    Event Action – Click
    Event Label – Test Link
    Event Value – 0
    Non-Interaction – False

    And added the following button to the page – Test Link

    I added the Google Analytics/Optimise tracking code to my WordPress theme’s header.php as follows:

    <script>
    (function(i,s,o,g,r,a,m){i[‘GoogleAnalyticsObject’]=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,’script’,’https://www.google-analytics.com/analytics.js&#8217;,’ga’);
    ga(‘create’, ‘XX-00000000-0’, ‘auto’);
    ga(‘require’, ‘XXX-0000000’);
    ga(‘send’, ‘pageview’);
    </script>

    Google Analytics is working for my site; it’s tracking page hits/views, geo-locations, etc.

    I haven’t added the same goal and ids in my Google Analytics account, as your tutorial didn’t cover it, I’m not sure if I needed to do that.

    Any help would be great, thanks in advance!
    Conor

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author yuvalo

    (@yuvalo)

    Hi @conorbryce

    I don’t see the plugin on the page. Have you disabled it?

    Yuval

    Thread Starter conorbryce

    (@conorbryce)

    Apologies, I’ve re-added it now – ‘Open Google’.

    Plugin Author yuvalo

    (@yuvalo)

    The plugin still seems to be disabled.

    Thread Starter conorbryce

    (@conorbryce)

    Sorry again! I’ve re-activated it. I had deactivated it a few days after I sent the first message, to test other issues.

    Plugin Author yuvalo

    (@yuvalo)

    @conorbryce,

    The element name should be a class that the button has.
    In this example, you could use “ctabutton”.

    You can also remove the onclick code because the plugin will take care of that for you.

    Yuval

    Thread Starter conorbryce

    (@conorbryce)

    Hi there,

    I’ve set up the button as detailed above, but it still isn’t triggering any event activity in my Google Analytics panel. Is there something in my site/theme that might be causing an issue with the data?

    Thanks,
    Conor

    Plugin Author yuvalo

    (@yuvalo)

    Now the button looks different and doesnt have the ctabutton and do have the gaConnect class.

    Can you make sure we are working on the same thing?

    Thread Starter conorbryce

    (@conorbryce)

    I’d removed the previous button and started from scratch, to avoid any complication, using your guidelines.

    I’ve used ‘gaConnect’ as the class on the button as that’s what I’ve named the class in the ‘Click Tracking’ window in your plugin settings. Should I change it to ‘ctabutton’?

    Plugin Author yuvalo

    (@yuvalo)

    Got it, no need to change anything.

    I did see an event going out to Google Analytics – can you take a look on their dashboard?

    Thread Starter conorbryce

    (@conorbryce)

    It’s appearing now, fantastic! Thanks for all your help, amazing plugin 🙂

    Plugin Author yuvalo

    (@yuvalo)

    Thanks, let me know if you run into any issues.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Event not tracking’ is closed to new replies.