Support » Plugin: Email Subscribers & Newsletters » Even at Version 4.0.3 not compliant to GDPR

  • Resolved olivermerk

    (@olivermerk)


    C’mon guys! Still double opt-in is not working. If I subscribe I am directly getting emails. That is not conform with german GDPR. Do you want that someone else can use your mail to set you on any newsletter list? Please focus on this.
    At the audience list there is no status column, although there is a status dropdown. I can use this to search for the status and this works. But all of the audience filters on status “Subscribed”.
    Although we are using your free plugin variant, we are not your beta testers! Not for such obvious functional problems. First test, then release…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Malay Ladu

    (@malayladu)

    Hi Oliver,

    We have tested Double Opt-In and it’s working without any issue.

    We have also checked with GDPR plugin. It also works fine with it.

    Please contact us. We will investigate into your issue.

    Even if I edit the Contact in the audience I am not getting the possibility to see his status or change it.

    According to the report this morning my new post was sent to a test email address, that has not double Opt-In. However, until now, I haven’t got the email to this address. Others on my audience list have got them.

    So maybe Double Opt-In is working with respect to not sending mails to them. However, they appear on the report list.

    And it is not good, that I don’t see the subscription status of my contacts and that I can’t edit it.

    Have you understand what double opt-in is? I’ve just checked the mail I’ve got after subscribing on my homepage and it contains the WELCOME email text, not the CONFIRMATION email text!!!

    Get this fixed! This is not legal in Europe!!!

    Plugin Contributor Malay Ladu

    (@malayladu)

    @olivermerk Make sure Double Opt-In option is set in Email Subscribers > Settings > General > Optin-Type fields.

    SORRY! My mistake. It was set to Single Opt-In!

    Is it possible that my settings were not converted properly from 3.5.18 to 4.0.0? I don’t remember that I have changed this setting after upgrade to 4.0.0.

    Now I’ve got the confirmation email. In the database table my contact_id is set to “unconfirmed”.
    And something that I’ve not realized yet: that the colored bullet next to List-column in Audience sections shows the status (yellow/green/red).

    Plugin Contributor Malay Ladu

    (@malayladu)

    @olivermerk Thanks for the confirmation.

    Is it possible that my settings were not converted properly from 3.5.18 to 4.0.0?

    Yes..there was a bug in migration which we already fixed.

    omething that I’ve not realized yet: that the colored bullet next to List-column in Audience sections shows the status (yellow/green/red)

    Yes..we have added that in 4.0.3.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Even at Version 4.0.3 not compliant to GDPR’ is closed to new replies.