Support » Plugin: EU/UK VAT Compliance Assistant for WooCommerce » European VAT Compliance for WooCommerce no tax visible by Product Variations

  • Resolved mvlaspld

    (@mvlaspld)


    I installed European VAT Compliance for WooCommerce and it works perfectly except for 1 thing and cant figure what is wrong.

    I have a lot of “Simple” Products and there no issues at all with the plugin.
    But have also Variable Products. Its a variable inside the product and will not be showed as separate product on the shop page.

    In my case I offers online books, and some books are available in multiple languages.
    Before the Card there is an selector that needs to be filled in by the customers before they can add this to the Card.

    With all “Simple” products the TAX calculations are done in the correct way, but on the “Variable Products” the plugin don’t work again and the TAX prices are not been visible. The Tax Class is the same as the parent, so in my opinion shouldn’t that be the case. Also the price of all variants for the same product are the same.

    Found some lines that can be added to function.php, but this not solved the issue,

    add_filter('woocommerce_get_price_html', 'edit_price_display', 10, 2);
    add_filter('woocommerce_get_variable_price_html', 'edit_price_display', 10, 2);

    Could you help me to have also prices displayed in the same way the Single products are showed.

    Beside, I ask this because the idea was to add a variation to all our product for a small upsell. All products are virtual products and no shipping is involved.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi,

    The plugin is not involved in how taxes are displayed on either simple or variable products – those are functions of WooCommerce itself. As such, it’s not something I know much about, since it’s not something I’ve programmed for in the plugin. Are you finding something different when the plugin is active compared to when it is inactive?

    David

    Thread Starter mvlaspld

    (@mvlaspld)

    I never tried it without the plugin, but I had disabled the plugin now and the issue remains, so its more an WooCommerce “bug / feature” then from the plugin.

    Appreciate the help and I will contact WooCommerce

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.