Support » Plugin: Jetpack by » Jetpack comments don't work after update to WP 3.5

  • Resolved sbbn



    I updated to WordPress 3.5 tonight, and now comments via Jetpack don’t work. When anyone tries to comment, they get “The page you requested could not be found” and a search box pops up. I turned off Jetpack comments which fixed the issue, but I would like to use the Jetpack comment feature if possible.

    Any thoughts? Thanks!

    (posted on How-Tos and Troubleshooting originally)

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic

    Do you have any other comment or Anti Spam plugins on your site?

    Could you also try to switch to Twenty Eleven or Twenty Twelve for a few minutes, and see if you experience the same problem?

    Hi! Sorry I haven’t responded sooner.

    I updated Jetpack tonight, but no improvement on the comments.

    I do have Bulletproof Security and WordPress Firewall 2 — I disabled both and tried Jetpack comments, but they still didn’t work.

    I changed to Twenty Eleven, and the same thing happened.

    What I notice happens is when I try to reply, I get the Page Not Found error, but my blog loads into the small comment box where my reply should be. So I see the top toolbar and my blog header where my reply had been, and below that, “The page you requested could not be found”. It’s very odd.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    Thanks for the additional details.

    Did you make any changes to your .htaccess file to harden your site security, or do you use any other security plugin that would have an effect on the iFrames on your site?

    Well, Bulletproof comes with a custom .htaccess file, and I did modify it with a few IP addresses of Russian hackers (using “allow,deny” commands). I did that a couple of weeks ago though, and it worked fine with the modifications then. That said, I DID update Bulletproof the same day I updated to WP 3.5, though when I disabled Bulletproof I assumed that custom .htaccess file was also disabled.

    I couldn’t tell you about iFrames, but the only two security plug-ins I use are WordPress Firewall 2 and Bulletproof, as I listed above. The only code modifications I’ve made in the last few months were adding those IPs on .htaccess.

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    Could you try to revert the changes and disable Bulletproof, and let me know if that helps?

    Okay, that worked.

    I disabled Bulletproof, went out on the Dashboard and updated the permalinks to get a new .htaccess file, reinstated the Jetpack comments and did a test comment. It went through fine this time.

    What precisely does this mean? I’ve seen others on the help forums indicate there is a Bulletproof Security problem (that I think involves javascript, if I’m understanding it correctly), so is Bulletproof the issue here? Does it cause problems with Jetpack?

    I’ve re-enabled Bulletproof as of now, btw.

    I’ve got the same comment error problem, although I don’t use Bulletproof. I do however use Stop Spammers. This is silly. As much as I like the smooth light comment plugin from Jetpack, it continues to break for one reason or another, so I guess It’s to be disabled until further notice…

    Plugin Author Jeremy Herve


    Jetpack Mechanic

    @sbbn While I am not familiar with the Bulletproof plugin, it probably disables iFrame features on your site. And since Jetpack Comments uses iFrames, the 2 plugins are not compatible.

    I would recommend that you contact the plugin author about it, and ask them if an option exists to turn this feature off in Bulletproof.

    @gabrielesque If you are looking for an Anti Spam software that is compatible with Jetpack Comments, I would recommend Akismet:

    Thanks Jeremy, I have asked on the Bulletproof forum.

    Note that the comments worked just fine with Bulletproof until the WP 3.5 update and the update to the more recent Bulletproof. Something obviously changed, but I’m not seeing a whole bunch of complaints about it, only a handful here and there. I wonder if this is theme dependent?

    @gabrielesque – I use Akismet with Jetpack comments and love it. That’s one reason why I’d really like to get Jetpack comments back on while also having Bulletproof security. Right now, because Jetpack comments are off, I get 10-15 spam comments a day that I have to manually delete.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Jetpack comments don't work after update to WP 3.5’ is closed to new replies.