Support » Fixing WordPress » Established wp blog redirecting to install.php

  • Resolved meg_meyer

    (@meg_meyer)


    Hello,

    Can you please help me?

    My established (over 1 year) wordpress blog is suddenly redirecting to an install.php page. I’ve done nothing to start this redirect. Is this a database problem? How do I check? How do I recover data?

    I did have a wordpress database manager plugin installed, if that helps.

    Thank you Soooooo much!

    Meg Meyer
    http://www.megmeyer.com

Viewing 13 replies - 1 through 13 (of 13 total)
  • Might make sure your WordPress and Blog addresses are correct:
    http://www.tamba2.org.uk/wordpress/site-url/

    Also make sure your .htaccess file isn’t causing the problem.

    Once I had a similar issue with a blog I manage for somebody – it was a DB issue and the host had to fix it.

    If the .htaccess is the problem, how do I know? How do I fix that?

    I’m also working with tech support, but they’re insisting it’s a wordpress problem and out of their service area. Moshu, any idea on what would need to be checked/corrected in the DB to make it work?

    Thanks guys!

    Meg Meyer

    I don’t remember the details but for sure when I tried to open the database in phpMyAdmin (that was installed on the server by host, as it should always be) – there were error messages of the kind we call “numbered errors”, i.e. like (errno: 123)

    So, if you have access to phpmyadmin, take a look at your DB.

    Ok, now the database seems to be working fine, but I’m still getting directed to install.php.

    What needs to be changed in .htaccess?

    index.php has been doublechecked and seems to be fine.

    Can anyone direct me to a good person to ask about this problem?

    Thanks!

    Meg Meyer

    Update:

    Database is working.

    I’ve re-copied .htaccess & index.php to the domain root. I’m hosting in a folder “blog. IE: hosted: http://www.megmeyer.com/blog/ Viewable at http://www.megmeyer.com.

    Currently:

    When accessing http://www.megmeyer.com/blog/ I get these error messages:

    Warning: require(./blog/wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/megmmey3/public_html/blog/index.php on line 17

    Warning: require(./blog/wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/megmmey3/public_html/blog/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘./blog/wp-blog-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/megmmey3/public_html/blog/index.php on line 17

    When I access from http://www.megmeyer.com I get:

    Not Found
    The requested URL /wp-admin/install.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Thoughts for what to try next?

    I really appreciate all your help!

    Meg Meyer

    whooami

    (@whooami)

    Member

    login to your hosts control panel, locate phpmyadmin, and double check that your options table is not corrupt, and that its actually there. Answering those 2 questions will entail more than this:

    now the database seems to be working fine

    there’s on function thats responsible for that redirect, and it looks for one thing, a working options table inside the database.

    whooami

    (@whooami)

    Member

    In response to this:

    Update:

    You are complicating things. Recopying files is NOT what you need to do. Stop.

    Fix ONE problem at a time.

    The first problem is the redirect.

    Its a secondary issue that that file, wp-admin/install.php isnt there.

    That you see the other errors is a result of where your files are and where your blog displays. Its not set up to load here:

    http://www.megmeyer.com/blog/

    Google that?! — nothing.

    Stop what you are doing, take some deep breaths, and check your database. “Its working” doesnt mean you see it. It means, like I said that there is an options table, and thats its NOT corrupt.

    You can check ALL your tables via phpmyadmin.

    I posted that before your tips were posted – can’t stop what was already done, but I thank you for your advice. 🙂

    How do I know the options table is corrupt or not? And what do I do if it IS corrupt?

    Those answers would be helpful, thank you for your input!

    Meg

    Ok, the options table from the table list says “In Use”. When I click through to the table I get the following error:

    #145 – Table ‘./megmmey3_wrdp1/wp_options’ is marked as crashed and should be repaired

    Can anyone suggest possible next steps? Thank you!

    Meg

    whooami

    (@whooami)

    Member

    1. Login to phpMyAdmin.
    2. Select the database and click on ‘Structure’ tab.
    3. Right under the list of table there is a “Check All” link. Click on it to select all tables.
    4. From a “With selected:” drop-down menu right next to it, choose “Check table”.

    To repair:

    http://www.google.com/search?hl=en&q=repair+database+tables+with+phpmyadmin&btnG=Search

    Awesome! That was exactly what I needed. Thank you, Whooami!

    W H O O A M I

    you are very great! you have solved many problems!

    and also you have solved my problems!

    THAANKSS!!!!!

    WE LOVE YOU

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Established wp blog redirecting to install.php’ is closed to new replies.