Support » Plugin: LiteSpeed Cache » ESI Widget Cache issue (trying to prevent widget from caching)

  • Resolved treeflips

    (@treeflips)


    I have a widget that keeps showing the same content even though I try to disable ESI cache on it! (set to PUBLIC or PRIVATE and 0 for TTL.

    You guys got ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Do you have object cache on ? try disable it and see how it goes

    also please enable debug log , we should see if the ESI sub-request is fired or not

    Best regards,

    Thread Starter treeflips

    (@treeflips)

    Object caching is definitely off. Debug log is on. do you know what the exact ESI line should be? I saw some mentions but not sure if I saw about the ESI sub-request as you say.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    you should see something like this

    07/13/20 08:51:35.198 [123.123.123.123:12346 1 PwX] 💓 ------GET HTTP/1.1 (HTTPS) /
    07/13/20 08:51:35.198 [123.123.123.123:12346 1 PwX] Query String: lsesi=widget&_control=private%2Cno-vary&esi=eyJuYW1lIjoiV1BfV2lkZ2V0X01ldGEiLCJpZCI6Im1ldGEtNCIsImluc3RhbmNlIjp7InRpdGx

    or like this

    07/13/20 08:49:54.077 [123.123.123.123:12346 1 eFQ] <!– lscwp widget WP_Widget_Search –><esi:include src=’/?lsesi=widget&_control=no-vary&esi=eyJuYW1lIjoiV1BfV2lkZ2V0X1NlYXJjaCIsImlkIjoic2VhcmNoLTQiLCJpbnN0YW5jZSI6eyJ0aXRsZSI6IiIsImxpdGVzcGVlZC1jYWNoZS1jb25mIjp7IndpZGdldF9lc2lfZW5hYmxlIjoxLCJ3aWRnZXRfdHRsIjo4NjQwMH19LCJhcmdzIjp7Im5hbWUiOiJcdTk5OTZcdTk4NzVcdTRmYTdcdThmYjlcdTY4MGYiLCJpZCI6InNpZGViYXItMSIsImRlc2NyaXB0aW9uIjoiXHU2NjNlXHU3OTNhXHU1NzI4XHU5OTk2XHU5ODc1XHU1M2NhXHU1MjA2XHU3YzdiXHU1ZjUyXHU2ODYzXHU5ODc1XHU0ZmE3XHU4ZmI5XHU2ODBmIiwiY2xhc3MiOiIiLCJiZWZvcmVfd2lkZ2V0IjoiPGFzaWRlIGlkPVwic2VhcmNoLTRcIiBjbGFzcz1cIndpZGdldCB3aWRnZXRfc2VhcmNoXCI%2BIiwiYWZ0ZXJfd2lkZ2V0IjoiPGRpdiBjbGFzcz1cImNsZWFyXCI%2BPFwvZGl2PjxcL2FzaWRlPiIsImJlZm9yZV90aXRsZSI6IjxoMyBjbGFzcz1cIndpZGdldC10aXRsZVwiPjxzcGFuIGNsYXNzPVwiY2F0XCI%2BIiwiYWZ0ZXJfdGl0bGUiOiI8XC9zcGFuPjxcL2gzPiIsIndpZGdldF9pZCI6InNlYXJjaC00Iiwid2lkZ2V0X25hbWUiOiJcdTY0MWNcdTdkMjIifX0%3D&_hash=0640f28277b47a0524b3477bbb23ee6c’ cache-control=’no-vary’ /><!– lscwp widget WP_Widget_Search esi end –>

    Best regards,

    Thread Starter treeflips

    (@treeflips)

    Hi,

    I was able to see those lines. Can I provide you access to the site backend and FTP? My client is really frustrated for this one and I couldn’t get it working after trying for so long.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please create a ticket here with reference of link to this topic

    Best regards,

    Thread Starter treeflips

    (@treeflips)

    Thank you, done!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ESI Widget Cache issue (trying to prevent widget from caching)’ is closed to new replies.