Support » Plugin: LiteSpeed Cache » esi shortcode with Caldera forms

  • Resolved jlahm

    (@jlahm)


    I am using Caldera Forms and have been getting the error message: “Submission rejected, token invalid”. I have tried adding the page name to the Exclude list, then purging the caches (browser’s too) and retrying, but the error persists. I found a page telling how to modify Caldera forms to use ESI, but was hesitant to change a plugin that could be subsequently updated by Caldera. Then I thought about using the new [esi] shortcode in the LiteSpeed Cache plugin. When I changed the page’s form shortcode from [caldera_form id=”CF5a98693025f5f”] to [esi caldera_form id=”CF5a98693025f5f”], the page now simply displays the original shortcode as text on the page (no form is displayed).

    What can I do to get the form working with caching? Thanks for your help.

    • This topic was modified 3 years ago by jlahm.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Hai Zheng⚡

    (@hailite)

    Do you have ESI enabled in setting?

    Thread Starter jlahm

    (@jlahm)

    Yes, I do have it enabled.

    However, I found the error and it was NOT due to the LiteSpeed cache. My original problem was caused by a conflict with using Plugin Organizer, and while I had the Caldera Form plugin enabled on the page, enabling Caldera site-wide seemed to be needed. I also found out that Caldera Forms has made their plugin ESI compliant and recommends adjusting the cache settings to expire in 10 hours. Using the ESI shortcode was not needed.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘esi shortcode with Caldera forms’ is closed to new replies.