Support » Plugin: eShop » eShop – Unable to Go Live

  • Resolved candres75



    I’ve installed eShop and gone through the set-up process, mostly using the eShop Wiki instructions at I’ve completed the global settings, set-up a department page and a product product page, etc. However, I am unable to go live.

    Initially I went to the “Going Live” section of the Wiki instructions. However, it simply says “Change the eShop Status to Live” without an explanation as to where or how to do that. I found that odd because the Going Live page lists several steps to take before going live and it explains exactly where and how to take these steps. But no explanation about where or how to go live.

    I then did an internet search on eShop going live and stumbled upon a Support Topic exchange (on from 5 months ago between lauracgeorge (user) and esmi (moderator) regarding the same topic. She was also unable to go live.

    In reading that string of 19 posts I was able to figure out the the toggle to Go Live should be on the Settings>eShop>General page. However, it is not present on my page. The eShop Status Pane is present saying that “eShop is currently in Test Mode – Merchant Gateways in use: Paypal”.

    However, the eShop Global Settings instructions in the eShop Wiki say that I should see settings for eShop Status (for toggling between Test and Live), Sale, Order Display, Cron, and Cacheability. But none of these things are present on my General page.

    Here is a link to a screenshot so you can see what I see.

    In addition, the options to set the Business Location and Currency Code are not present on the Merchant Gateway Page either.

    I followed the instructions you provided to lauracgeorge 5 months ago, which I also saw in the Troubleshooting section of the eShop Wiki under the heading “Can’t Switch eShop to Live”. I performed all of the following instructions and it still hasn’t solved the problem:

    [1] Switch back to two columns (if you haven’t already) via Screen Options on the Settings → eShop → General page
    [2] Empty your browser cache
    [3] Close your browser then re-open it.
    [4] Try a different browser.
    [5] Try a different machine
    [6] Try creating another admin user, then logging out of your old admin account and logging in as the new admin user
    [7] If you continue to have problems despite carrying out all of these steps, try installing & activating the Google Libraries plugin to force a true jQuery browser flush.

    I activated the Google Libraries plugin as well and still no luck.

    I hope you have a solution for me. I’ve spent a lot of time setting all this up and eShop seemed like it would be a great solution.

    Also, can you provide a screenshot of the Settings>eShop>General Page to show me what the missing options (example: toggle between Test Mode & Live, Cache, etc.) should look like? It would be very helpful if I knew what I was looking for.

    Can you provide a screenshot of the Settings>eShop>Merchant Gateway Page as well to who what the Business Location and Currency Code fields should look like? This would be helpful as well.

    Thank you in advance for helping me with this. I’m baffled and frustrated at this point.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I should mention one other thing. The first troubleshooting step:

    [1] Switch back to two columns (if you haven’t already) via Screen Options on the Settings → eShop → General page

    This was not possible. There is no option on my General Page to switch the view to 2 columns.

    As I’m sure is typical, the problem appears to be solved. I went through the recommended steps to solve the problem again. Selecting the ‘Screen Options’ menu at the top right of the screen in WordPress, and changing the ‘Number of Columns’ from 1 to 2 in the ‘Screen Layout’ setting did the trick.

    Thanks anyway.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘eShop – Unable to Go Live’ is closed to new replies.