WordPress.org

Support

Support » Plugins and Hacks » eShop Images

eShop Images

  • Hi This is the best and easiest cart to use and until the recent updates it has been working like a charm.

    My problem is the loss of images. For list sub pages; all my images have been replaced with the default basket image. I have tried 6 ways to next Tuesday to upload, insert my images again to no avail. When I click on the thumb in the products page it use to bring up the images that were associated with that particular product and you could choose an image. Now when I click on that image instead of taking me to my images it takes me to that page on the live site.

    I have also tried using WordPress’s Page Image and that doesn’t work either. I have followed threads here and on your forum but have not found anything that works. Any advise would be greatly appreciated. If you need my site it is http://studiostore.ca

    Thanks

    http://wordpress.org/extend/plugins/eshop/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Hi artbiz,

    I had to upgrade a client’s site to WP 3.0.

    Once I did, a link appears in the right column of each product page called “Set featured image”.

    Clicking on this link, I could post thumbnails for my client’s products (paintings):

    Biker Art

    I had to select thumbnails for each product, which wasn’t so bad since there are only three paintings.

    Unfortunately, if you have a lot of products, it’s going to be a bit of a pain.

    Hope that works for you.

    Reed

    Thanks for suggestion. I actually tried that this morning on another site. I was able to select a feature image for the page on a whole and I have always been able to get an image for the individual products pages but still can not achieve an image that will appear for eshop_list_subpages or eshop_list_products id=” panels=’yes’ form=’yes’

    The eShop/Products/ thumbnail will not let me choose a thumb in WordPress 3.0 and sends me to the live page as well.

    Hey but thanks!

    You have to use the featured image (or whatever it is called now) that is available on the edit screen for the product. eShop will automatically use whatever you set up.

    The default image was added in because I knew the change was going to affect everyone that was using the plugin – but I had no way of transferring the previous data to the new method.

    Sorry to say that I have tried that. Images will not appear for eshop_list_subpages or eshop_list_products id=” panels=’yes’ form=’yes’

    Is the feature to select a product thumbnail still suppose to be available on the eshop/products page? My install sends me to the live page where you use to be able to select (via radio button) an image.

    no you must select the thumbnail via the edit screen for the post/page.

    It is called Featured image, and should be in the right hand column.

    Yes Elfin that is what I have been doing.

    The problem is that eShop isn’t grabbing those images and showing them when I add the code [ eshop_list_subpages ] on a page other than an individual products page.

    Is there a step that I am missing?

    possibly, can you give me the url of a page with that shortcode on please.

    how is the block with thumbnails above generated?

    It is just a table filled with linked images until I can get my eShop images back

    I’ve just double checked and it definetly works for me.

    Have you got any other active plugins? (if so try diabling them and check that page), also try a different theme (twentyten?)

    Okay that will take a while. I will let you know the results.

    I really appreciate your help, thanks.

    That didn’t take as long as I thought.

    I disabled the plugin’s one by one and checked the page each time and cleared my cache as well.

    I upgraded to 3.0 and changed my theme to twenty-ten and I’m afraid the problem persists.

    Should I try to uninstall eShop completely and try a fresh new install?

    shouldn’t be necessary

    if you’re prepared to give me a login, email me elfin@elfden.co.uk and I’ll take a look.

    Apparently I missed a step. When you choose your feature image with the link on the right of the page editor you also have to click a link in the media pop up window that say “set as feature image”. Never noticed it until Elfin set me straight.

    Thanks for the great support!

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘eShop Images’ is closed to new replies.